# CVE-2024-58366: SurrealDB before 1.1.1 Format String via Scripting Functions

> Attackers with scripting privileges can exploit a format string vulnerability in SurrealDB to read arbitrary memory or execute code.

- **Severity:** Critical 9.0 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Jul 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-q3gg-m8hr-h4x4, GHSA-qcfm-cmfw-f4x4

## What is CVE-2024-58366?

CVE-2024-58366 is a critical vulnerability in Surrealdb Surrealdb, published on 18 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

SurrealDB before 1.1.1 contains a format string vulnerability in the rquickjs Exception::throw_type function when scripting is enabled. Attackers with scripting privileges can supply format string sequences in error inputs to read arbitrary memory or execute code with SurrealDB process privileges.

Weakness: CWE-134 (Use of Externally-Controlled Format String)

## Which versions are affected by CVE-2024-58366?

2 open source packages ship an affected version, including surrealdb. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `surrealdb` | crates.io | All versions | 1.1.1 |
| `surrealdb` | crates.io | All versions | 1.1.1 |

Products: Delskayn Rquickjs, Surrealdb Surrealdb.

## How do I fix CVE-2024-58366?

Upgrade surrealdb to 1.1.1 or later.

## Is CVE-2024-58366 being exploited?

There is no known exploitation of CVE-2024-58366 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-58366 and fix it if it is affected.

What it is: CVE-2024-58366 is a critical vulnerability in Surrealdb Surrealdb, published on 18 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-58366 in the wild and no public exploit code.

Affected packages and fixed versions:
- surrealdb (crates.io): affected all versions; fixed in 1.1.1
- surrealdb (crates.io): affected all versions; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-58366/ (Markdown: https://insights.sbomify.com/CVE-2024-58366/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-58366
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-58366
- OSV: https://osv.dev/vulnerability/CVE-2024-58366

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-58366/
Summaries are generated and may contain mistakes; the official description above is the record.
