{"answers":{"affected":"2 open source packages ship an affected version, including surrealdb. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-58370 in the wild and no public exploit code.","fix":"Upgrade surrealdb to 1.1.0 or later.","what":"CVE-2024-58370 is a high-severity denial of service vulnerability in Surrealdb Surrealdb, published on 18 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-58370 and fix it if it is affected.\n\nWhat it is: CVE-2024-58370 is a high-severity denial of service vulnerability in Surrealdb Surrealdb, published on 18 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-58370 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- surrealdb (crates.io): affected all versions; fixed in 1.1.0\n- surrealdb (crates.io): affected all versions; fixed in 1.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-58370/ (Markdown: https://insights.sbomify.com/CVE-2024-58370/index.md)","id":"CVE-2024-58370","markdown":"https://insights.sbomify.com/CVE-2024-58370/index.md","name":"CVE-2024-58370","record":{"aliases":["GHSA-6r8p-hpg7-825g","GHSA-qv48-pw56-mwc4"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"SurrealDB database","requires_auth":"low_privilege","summary":"Authorized attackers can crash the SurrealDB server by submitting deeply nested queries, causing a stack overflow.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[{"product":"surrealdb","vendor":"surrealdb"}],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"SurrealDB versions before 1.1.0 fail to enforce recursion depth limits when parsing nested SurrealQL statements including IF, RELATE, and attribute access idioms. Authorized attackers can submit queries with excessive nesting depth to cause stack overflow and crash the server.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"SurrealDB before 1.1.0 Uncontrolled Recursion Denial of Service","id":"CVE-2024-58370","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":"surrealdb:surrealdb","products":["surrealdb:surrealdb"],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Hongjing e-HR Unauthenticated SQL Injection via getSdutyTree","id":"CVE-2024-58374"},"packages":[{"ecosystem":"crates.io","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"surrealdb","purl":null,"source":"GHSA-6r8p-hpg7-825g"},{"ecosystem":"crates.io","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"surrealdb","purl":"pkg:cargo/surrealdb","source":"GHSA-6r8p-hpg7-825g"}],"prev":{"headline":"SurrealDB before 1.1.1 Denial of Service via Global Parameters","id":"CVE-2024-58369"},"products":["surrealdb"],"published":"2026-07-18","related":[{"cvss_score":9.4,"headline":"SurrealDB before 2.2.2 SurrealQL Injection via export","id":"CVE-2025-71392","kev_date_added":null,"published":"2026-07-18"},{"cvss_score":9.2,"headline":"SurrealDB before 3.1.0 Privilege Escalation via RPC Session Race Condition","id":"CVE-2026-63756","kev_date_added":null,"published":"2026-07-20"},{"cvss_score":8.7,"headline":"SurrealDB before 3.1.0 Denial of Service via malformed RPC use","id":"CVE-2026-63747","kev_date_added":null,"published":"2026-07-20"},{"cvss_score":8.7,"headline":"SurrealDB before 3.1.0 Session Hijacking via /rpc sessions","id":"CVE-2026-63757","kev_date_added":null,"published":"2026-07-20"},{"cvss_score":8.7,"headline":"SurrealDB before 3.1.0 Denial of Service via JSON Parser","id":"CVE-2026-63760","kev_date_added":null,"published":"2026-07-20"},{"cvss_score":8.7,"headline":"SurrealDB before 1.0.1 Insecure Default Table Permissions","id":"CVE-2023-54366","kev_date_added":null,"published":"2026-07-18"},{"cvss_score":8.7,"headline":"SurrealDB before 1.5.5 Query Injection via RPC API","id":"CVE-2024-58362","kev_date_added":null,"published":"2026-07-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-28","vendors":["surrealdb"]},"summary":"Authorized attackers can crash the SurrealDB server by submitting deeply nested queries, causing a stack overflow.","url":"https://insights.sbomify.com/CVE-2024-58370/"}