{"answers":{"affected":"2 open source packages ship an affected version, including nokogiri.","exploited":"There is no known exploitation of CVE-2024-58377 in the wild and no public exploit code.","fix":"Upgrade nokogiri to 1.16.5 or later.","what":"CVE-2024-58377 is a vulnerability in nokogiri, published on 25 Aug 2026."},"fix_prompt":"Check this codebase for CVE-2024-58377 and fix it if it is affected.\n\nWhat it is: CVE-2024-58377 is a vulnerability in nokogiri, published on 25 Aug 2026. \nExploitation: There is no known exploitation of CVE-2024-58377 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nokogiri (RubyGems): affected all versions; fixed in 1.16.5\n- nokogiri (RubyGems): affected all versions; fixed in 1.16.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-58377/ (Markdown: https://insights.sbomify.com/CVE-2024-58377/index.md)","id":"CVE-2024-58377","markdown":"https://insights.sbomify.com/CVE-2024-58377/index.md","name":"CVE-2024-58377","record":{"aliases":["GHSA-r95h-9x8f-r3f7","GHSA-rpqg-75pv-92c9"],"analysis":null,"analysis_generated_by":null,"assigner":"VulnCheck","cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"This CVE ID has been rejected as a duplicate.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Nokogiri updates packaged libxml2 to v2.12.7 to resolve CVE-2024-34459","id":"CVE-2024-58377","indexable":false,"kev":null,"kind":"cve_rejected","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":null,"year":"2024"},"n_packages":2,"n_references":0,"next":{"headline":"This CVE ID has been rejected as a duplicate.","id":"CVE-2024-58378"},"packages":[{"ecosystem":"RubyGems","fixed":["1.16.5"],"introduced":["0"],"last_affected":[],"package":"nokogiri","purl":null,"source":"GHSA-r95h-9x8f-r3f7"},{"ecosystem":"RubyGems","fixed":["1.16.5"],"introduced":["0"],"last_affected":[],"package":"nokogiri","purl":"pkg:gem/nokogiri","source":"GHSA-r95h-9x8f-r3f7"}],"prev":{"headline":"Renovate 37.158.0 before 37.199.0 Command Injection via helmv3","id":"CVE-2024-58376"},"products":[],"published":"2026-08-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"REJECTED","updated":"2026-09-01","vendors":[]},"summary":null,"url":"https://insights.sbomify.com/CVE-2024-58377/"}