# CVE-2024-58379: nodemailer before 6.9.9 ReDoS via attachDataUrls parameter

> Attackers can cause a denial of service in nodemailer by sending crafted emails when the attachDataUrls parameter is enabled.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** DEBIAN-CVE-2024-58379, GHSA-7mr3-4pph-3qpg, GHSA-9h6g-pr28-7cqp, UBUNTU-CVE-2024-58379

## What is CVE-2024-58379?

CVE-2024-58379 is a medium-severity denial of service vulnerability in nodemailer, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

nodemailer before 6.9.9 contains a regular expression denial of service vulnerability in email parsing when attachDataUrls parameter is set or processing embedded file attachments. Attackers can send specially crafted emails with malicious data URLs or embedded attachments to cause the event loop to hang and deny service.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2024-58379?

2 open source packages ship an affected version, including nodemailer.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nodemailer` | npm | All versions | 6.9.9 |
| `nodemailer` | npm | All versions | 6.9.9 |

## How do I fix CVE-2024-58379?

Upgrade nodemailer to 6.9.9 or later.

## Is CVE-2024-58379 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-58379 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-58379 and fix it if it is affected.

What it is: CVE-2024-58379 is a medium-severity denial of service vulnerability in nodemailer, published on 31 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-58379 exists.

Affected packages and fixed versions:
- nodemailer (npm): affected all versions; fixed in 6.9.9
- nodemailer (npm): affected all versions; fixed in 6.9.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-58379/ (Markdown: https://insights.sbomify.com/CVE-2024-58379/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-58379
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-58379
- OSV: https://osv.dev/vulnerability/CVE-2024-58379

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-58379/
Summaries are generated and may contain mistakes; the official description above is the record.
