# CVE-2024-58380: PocketMine-MP before 5.11.2 Denial of Service via BookEditPacket

> Attackers can crash the PocketMine-MP server by sending a crafted BookEditPacket with an invalid inventory slot value.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-238x-cw5p-56x5, GHSA-xc7j-wj36-qjfr

## What is CVE-2024-58380?

CVE-2024-58380 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PocketMine-MP versions before 5.11.2 contain a denial of service vulnerability in BookEditPacket handling that crashes the server when an invalid inventory slot value is provided. Attackers can send a crafted BookEditPacket with an inventory slot greater than 35 to trigger an unhandled exception and crash the server.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-58380?

2 open source packages ship an affected version, including pocketmine/pocketmine-mp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pocketmine/pocketmine-mp` | Packagist | All versions | 5.11.2 |
| `pocketmine/pocketmine-mp` | Packagist | All versions | 5.11.2 |

## How do I fix CVE-2024-58380?

Upgrade pocketmine/pocketmine-mp to 5.11.2 or later.

## Is CVE-2024-58380 being exploited?

There is no known exploitation of CVE-2024-58380 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-58380 and fix it if it is affected.

What it is: CVE-2024-58380 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-58380 in the wild and no public exploit code.

Affected packages and fixed versions:
- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 5.11.2
- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 5.11.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-58380/ (Markdown: https://insights.sbomify.com/CVE-2024-58380/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-58380
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-58380
- OSV: https://osv.dev/vulnerability/CVE-2024-58380

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-58380/
Summaries are generated and may contain mistakes; the official description above is the record.
