# CVE-2024-58381: PocketMine-MP before 5.11.1 Denial of Service via LoginPacket

> Remote attackers can crash the PocketMine-MP server by sending malformed JSON data in LoginPacket, requiring an upgrade to fix.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-h6j3-j35f-v2x7, GHSA-w3w8-r2xc-3rp3

## What is CVE-2024-58381?

CVE-2024-58381 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PocketMine-MP before 5.11.1 contains a denial of service vulnerability in LoginPacket JSON processing that allows remote attackers to crash the server by sending malformed JSON data. Attackers can exploit improper object initialization from scalar JSON types to trigger unset required properties, causing the application to crash.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2024-58381?

2 open source packages ship an affected version, including pocketmine/pocketmine-mp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pocketmine/pocketmine-mp` | Packagist | All versions | 5.11.1 |
| `pocketmine/pocketmine-mp` | Packagist | All versions | 5.11.1 |

## How do I fix CVE-2024-58381?

Upgrade pocketmine/pocketmine-mp to 5.11.1 or later.

## Is CVE-2024-58381 being exploited?

There is no known exploitation of CVE-2024-58381 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-58381 and fix it if it is affected.

What it is: CVE-2024-58381 is a high-severity denial of service vulnerability in pmmp PocketMine-MP, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-58381 in the wild and no public exploit code.

Affected packages and fixed versions:
- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 5.11.1
- pocketmine/pocketmine-mp (Packagist): affected all versions; fixed in 5.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-58381/ (Markdown: https://insights.sbomify.com/CVE-2024-58381/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-58381
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-58381
- OSV: https://osv.dev/vulnerability/CVE-2024-58381

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-58381/
Summaries are generated and may contain mistakes; the official description above is the record.
