{"answers":{"affected":"2 open source packages ship an affected version, including league/commonmark.","exploited":"There is no known exploitation of CVE-2024-58382 in the wild and no public exploit code.","fix":"Upgrade league/commonmark to 2.6.0 or later.","what":"CVE-2024-58382 is a high-severity denial of service vulnerability in thephpleague commonmark, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-58382 and fix it if it is affected.\n\nWhat it is: CVE-2024-58382 is a high-severity denial of service vulnerability in thephpleague commonmark, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-58382 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- league/commonmark (Packagist): affected all versions; fixed in 2.6.0\n- league/commonmark (Packagist): affected all versions; fixed in 2.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-58382/ (Markdown: https://insights.sbomify.com/CVE-2024-58382/index.md)","id":"CVE-2024-58382","markdown":"https://insights.sbomify.com/CVE-2024-58382/index.md","name":"CVE-2024-58382","record":{"aliases":["CLSA-2025-1766364770","DEBIAN-CVE-2024-58382","GHSA-c2pc-g5qf-rfrf","GHSA-fv22-86fq-c33q"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP Markdown library","requires_auth":"none","summary":"Attackers can cause denial of service by submitting crafted Markdown inputs that trigger quadratic complexity in the league/commonmark PHP library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-407","name":"Inefficient Algorithmic Complexity"}],"description":"league/commonmark versions before 2.6.0 contain polynomial time complexity vulnerabilities in Markdown parsing that allow attackers to cause denial of service. Attackers can submit carefully crafted Markdown inputs designed to trigger worst-case performance, and sending multiple requests in parallel exhausts CPU resources and PHP-FPM processes.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"league/commonmark before 2.6.0 Denial of Service via Quadratic Complexity","id":"CVE-2024-58382","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Froxlor before 2.2.0 Insecure File Permissions mysql.conf","id":"CVE-2024-58383"},"packages":[{"ecosystem":"Packagist","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"league/commonmark","purl":null,"source":"GHSA-c2pc-g5qf-rfrf"},{"ecosystem":"Packagist","fixed":["2.6.0"],"introduced":["0"],"last_affected":[],"package":"league/commonmark","purl":"pkg:composer/league/commonmark","source":"GHSA-c2pc-g5qf-rfrf"}],"prev":{"headline":"PocketMine-MP before 5.11.1 Denial of Service via LoginPacket","id":"CVE-2024-58381"},"products":["commonmark"],"published":"2026-09-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-08","vendors":["thephpleague"]},"summary":"Attackers can cause denial of service by submitting crafted Markdown inputs that trigger quadratic complexity in the league/commonmark PHP library.","url":"https://insights.sbomify.com/CVE-2024-58382/"}