# CVE-2024-58382: league/commonmark before 2.6.0 Denial of Service via Quadratic Complexity

> Attackers can cause denial of service by submitting crafted Markdown inputs that trigger quadratic complexity in the league/commonmark PHP library.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** CLSA-2025-1766364770, DEBIAN-CVE-2024-58382, GHSA-c2pc-g5qf-rfrf, GHSA-fv22-86fq-c33q

## What is CVE-2024-58382?

CVE-2024-58382 is a high-severity denial of service vulnerability in thephpleague commonmark, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

league/commonmark versions before 2.6.0 contain polynomial time complexity vulnerabilities in Markdown parsing that allow attackers to cause denial of service. Attackers can submit carefully crafted Markdown inputs designed to trigger worst-case performance, and sending multiple requests in parallel exhausts CPU resources and PHP-FPM processes.

Weakness: CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2024-58382?

2 open source packages ship an affected version, including league/commonmark.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `league/commonmark` | Packagist | All versions | 2.6.0 |
| `league/commonmark` | Packagist | All versions | 2.6.0 |

## How do I fix CVE-2024-58382?

Upgrade league/commonmark to 2.6.0 or later.

## Is CVE-2024-58382 being exploited?

There is no known exploitation of CVE-2024-58382 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-58382 and fix it if it is affected.

What it is: CVE-2024-58382 is a high-severity denial of service vulnerability in thephpleague commonmark, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-58382 in the wild and no public exploit code.

Affected packages and fixed versions:
- league/commonmark (Packagist): affected all versions; fixed in 2.6.0
- league/commonmark (Packagist): affected all versions; fixed in 2.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-58382/ (Markdown: https://insights.sbomify.com/CVE-2024-58382/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-58382
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-58382
- OSV: https://osv.dev/vulnerability/CVE-2024-58382

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-58382/
Summaries are generated and may contain mistakes; the official description above is the record.
