# CVE-2024-58383: Froxlor before 2.2.0 Insecure File Permissions mysql.conf

> Local attackers can read world-readable database credentials to gain admin access and root privileges in Froxlor installations using pure-ftpd.

- **Severity:** High 8.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 Sep 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-34qg-65m4-f23m, GHSA-x2wh-r8m8-h3h3

## What is CVE-2024-58383?

CVE-2024-58383 is a high-severity vulnerability in froxlor, published on 14 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Froxlor before 2.2.0 (affected up to and including 2.2.0-rc3) generates /etc/pure-ftpd/db/mysql.conf with mode 0644 via the XML configuration templates in lib/configfiles/, even though the file contains the Froxlor SQL user's password. On systems where the parent directories are world readable (the default on Debian 12), any unprivileged local user able to execute commands or code on the host — including virtual users without SSH access who can upload PHP/CGI scripts — can read the file and obtain the Froxlor database credentials. Database access can then be leveraged to alter an administrator's password hash and TOTP seed, log in as a Froxlor administrator, and ultimately gain root privileges. Only instances configured to use pure-ftpd are affected.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2024-58383?

2 open source packages ship an affected version, including froxlor/froxlor.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `froxlor/froxlor` | Packagist | All versions | 2.2.0 |
| `froxlor/froxlor` | Packagist | All versions | 2.2.0 |

## How do I fix CVE-2024-58383?

Upgrade froxlor/froxlor to 2.2.0 or later.

## Is CVE-2024-58383 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-58383 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-58383 and fix it if it is affected.

What it is: CVE-2024-58383 is a high-severity vulnerability in froxlor, published on 14 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-58383 exists.

Affected packages and fixed versions:
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.2.0
- froxlor/froxlor (Packagist): affected all versions; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-58383/ (Markdown: https://insights.sbomify.com/CVE-2024-58383/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-58383
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-58383
- OSV: https://osv.dev/vulnerability/CVE-2024-58383

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-58383/
Summaries are generated and may contain mistakes; the official description above is the record.
