# CVE-2024-58384: Tornado before 6.4.1 CRLF Injection via CurlAsyncHTTPClient

> Attackers can inject CRLF sequences into HTTP headers via CurlAsyncHTTPClient to manipulate requests or inject arbitrary headers.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** AZL-103104, DEBIAN-CVE-2024-58384, ECHO-9a82-341f-f71d, GHSA-qf37-5gqv-7f3m, GHSA-w235-7p84-xx57, ROOT-APP-PYPI-GHSA-w235-7p84-xx57, UBUNTU-CVE-2024-58384

## What is CVE-2024-58384?

CVE-2024-58384 is a medium-severity vulnerability in tornadoweb tornado, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Tornado before 6.4.1 contains a CRLF injection vulnerability in CurlAsyncHTTPClient that fails to reject carriage return and line feed characters in request headers. Attackers can inject CRLF sequences into header values to inject arbitrary headers or construct entirely new HTTP requests.

Weakness: CWE-113 (Improper Neutralization of CRLF Sequences in HTTP Headers)

## Which versions are affected by CVE-2024-58384?

2 open source packages ship an affected version, including tornado.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tornado` | PyPI | All versions | 6.4.1 |
| `tornado` | PyPI | All versions | 6.4.1 |

## How do I fix CVE-2024-58384?

Upgrade tornado to 6.4.1 or later.

## Is CVE-2024-58384 being exploited?

There is no known exploitation of CVE-2024-58384 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-58384 and fix it if it is affected.

What it is: CVE-2024-58384 is a medium-severity vulnerability in tornadoweb tornado, published on 15 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-58384 in the wild and no public exploit code.

Affected packages and fixed versions:
- tornado (PyPI): affected all versions; fixed in 6.4.1
- tornado (PyPI): affected all versions; fixed in 6.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-58384/ (Markdown: https://insights.sbomify.com/CVE-2024-58384/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-58384
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-58384
- OSV: https://osv.dev/vulnerability/CVE-2024-58384

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-58384/
Summaries are generated and may contain mistakes; the official description above is the record.
