CVE-2024-58398 Coder 2.3.1 before 2.16.1 Open Redirect via Login Page redirect Parameter
Attackers can craft malicious login URLs to redirect logged-in users to attacker-controlled sites, facilitating phishing attacks against Coder users.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-58398?
CVE-2024-58398 is a medium-severity vulnerability in coder, published on 17 Oct 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Coder 2.3.1 before 2.14.4, 2.15.x before 2.15.3, and 2.16.0 before 2.16.1 contains an open redirect vulnerability in the login page because the redirect query parameter is improperly sanitized. Attackers can craft a Coder login URL that, when clicked by a logged-in user, redirects the victim to an attacker-controlled website for phishing.
Weakness: CWE-601
Which versions are affected by CVE-2024-58398?
8 open source packages ship an affected version, including github.com/coder/coder/v2 and github.com/coder/coder.
| Package | Affected | Fixed in |
|---|---|---|
github.com/coder/coder/v2 Go | From 2.15.0 | 2.15.3 |
github.com/coder/coder/v2 Go | From 2.15.0 | 2.15.3 |
github.com/coder/coder/v2 Go | From 2.16.0 | 2.16.1 |
github.com/coder/coder/v2 Go | From 2.16.0 | 2.16.1 |
github.com/coder/coder/v2 Go | From 2.3.1 | 2.14.4, 2.15.3, 2.16.1 |
github.com/coder/coder/v2 Go | From 2.3.1 | 2.14.4 |
2 more packages
github.com/coder/coder/v2 Go | From 2.3.1 | 2.14.4 |
github.com/coder/coder Go | All versions | None |
How do I fix CVE-2024-58398?
Upgrade github.com/coder/coder/v2 to a fixed version for your release line: 2.15.3, 2.16.1 or 2.14.4.
Is CVE-2024-58398 being exploited?
There is no known exploitation of CVE-2024-58398 in the wild and no public exploit code.
Sources
Also known as GHSA-7pxf-q642-mp95, GHSA-wcx9-ccpj-hx3c, GO-2024-3228.