# CVE-2024-5945: WP SVG Images <= 4.3 - Authenticated (Author+) Stored Cross-Site Scripting via SVG

> Authenticated attackers can inject arbitrary scripts via SVG uploads, leading to stored XSS execution on victim pages.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 21 Jun 2024
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-jm7q-rxr5-2rpf

## What is CVE-2024-5945?

CVE-2024-5945 is a medium-severity cross-site scripting vulnerability in shortpixel WP SVG Images, published on 21 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The WP SVG Images plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘type’ parameter in all versions up to, and including, 4.3 due to insufficient input sanitization. This makes it possible for authenticated attackers, with Author-level access and above, who have permissions to upload sanitized files, to bypass SVG sanitization and inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. A bypass to the patch in version 4.3 was discovered and fixed completely in version 4.4.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-5945?

It affects 1 product.


Products: Kubiq Wp Svg Images.

## How do I fix CVE-2024-5945?

No fix has been published for CVE-2024-5945 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-5945 being exploited?

There is no known exploitation of CVE-2024-5945 in the wild and no public exploit code.

## Other vulnerabilities in shortpixel WP SVG Images

- [CVE-2021-24386](https://insights.sbomify.com/CVE-2021-24386/): WP SVG Images < 3.4 - Authenticated (author+) Stored XSS via SVG (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-5945 and fix it if it is affected.

What it is: CVE-2024-5945 is a medium-severity cross-site scripting vulnerability in shortpixel WP SVG Images, published on 21 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-5945 in the wild and no public exploit code.

Affected product: shortpixel WP SVG Images. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-5945/ (Markdown: https://insights.sbomify.com/CVE-2024-5945/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-5945
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-5945
- OSV: https://osv.dev/vulnerability/CVE-2024-5945

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-5945/
Summaries are generated and may contain mistakes; the official description above is the record.
