{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-5987 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-5987 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-5987 is a medium-severity missing authorization vulnerability in vol4ikman WP Accessibility Helper (WAH), published on 29 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-5987 and fix it if it is affected.\n\nWhat it is: CVE-2024-5987 is a medium-severity missing authorization vulnerability in vol4ikman WP Accessibility Helper (WAH), published on 29 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-5987 in the wild and no public exploit code.\n\nAffected product: vol4ikman WP Accessibility Helper (WAH). No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-5987/ (Markdown: https://insights.sbomify.com/CVE-2024-5987/index.md)","id":"CVE-2024-5987","markdown":"https://insights.sbomify.com/CVE-2024-5987/index.md","name":"CVE-2024-5987","record":{"aliases":["GHSA-6qr3-hrff-mm2p"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Authenticated subscribers can modify accessibility contrast settings due to missing capability checks in the WP Accessibility Helper plugin.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"wp_accessibility_helper","vendor":"volkov"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"The WP Accessibility Helper (WAH) plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'save_contrast_variations' and 'save_empty_contrast_variations' functions in all versions up to, and including, 0.6.2.8. This makes it possible for authenticated attackers, with Subscriber-level access and above, to edit or delete contrast settings.  Please note these issues were patched in 0.6.2.8, though it broke functionality and the vendor has not responded to our follow-ups.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"WP Accessibility Helper \u003c= 0.6.2.8 - Missing Authorization to Authenticated (Subscriber+) Limited Settings Update","id":"CVE-2024-5987","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"missing_authorization","year":"2024"},"n_packages":0,"n_references":2,"next":{"headline":"Rockwell Automation ThinManager® ThinServer™ Improper Input Validation Vulnerability","id":"CVE-2024-5988"},"packages":[],"prev":{"headline":"Remote Arbitrary File Write with Arbitrary Data in h2oai/h2o-3","id":"CVE-2024-5986"},"products":["WP Accessibility Helper (WAH)"],"published":"2024-08-29","related":[{"cvss_score":4.3,"headline":"WordPress WP Accessibility Helper (WAH) plugin \u003c= 0.6.2.5 - Broken Access Control vulnerability","id":"CVE-2024-31423","kev_date_added":null,"published":"2024-06-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["vol4ikman"]},"summary":"Authenticated subscribers can modify accessibility contrast settings due to missing capability checks in the WP Accessibility Helper plugin.","url":"https://insights.sbomify.com/CVE-2024-5987/"}