{"answers":{"affected":"4 open source packages ship an affected version, including langchain-community and langchain. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5998 exists.","fix":"Upgrade langchain-community to 0.2.4 or later.","what":"CVE-2024-5998 is a medium-severity unsafe deserialization vulnerability in langchain-ai/langchain, published on 17 Sep 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-5998 and fix it if it is affected.\n\nWhat it is: CVE-2024-5998 is a medium-severity unsafe deserialization vulnerability in langchain-ai/langchain, published on 17 Sep 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5998 exists.\n\nAffected packages and fixed versions:\n- langchain-community (PyPI): affected all versions; fixed in 0.2.4\n- langchain-community (PyPI): affected all versions; fixed in 0.2.4\n- langchain-community (PyPI): affected all versions; fixed in 0.2.4\n- langchain (PyPI): affected all versions; fixed in 0.2.9\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-5998/ (Markdown: https://insights.sbomify.com/CVE-2024-5998/index.md)","id":"CVE-2024-5998","markdown":"https://insights.sbomify.com/CVE-2024-5998/index.md","name":"CVE-2024-5998","record":{"aliases":["GHSA-f2jm-rw3h-6phg","PYSEC-2024-323","PYSEC-2026-1514"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python AI library","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary commands via unsafe pickle deserialization in the FAISS module of the LangChain library.","user_interaction":"required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[{"product":"langchain","vendor":"langchain"}],"cvss":{"score":5.2,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:P/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:L","version":"3.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"A vulnerability in the FAISS.deserialize_from_bytes function of langchain-ai/langchain allows for pickle deserialization of untrusted data. This can lead to the execution of arbitrary commands via the os.system function. The issue affects the latest version of the product.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Deserialization of Untrusted Data in langchain-ai/langchain","id":"CVE-2024-5998","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"deserialization","year":"2024"},"n_packages":4,"n_references":2,"next":{"headline":"FooEvents for WooCommerce \u003c= 1.19.20 - Improper Authorization to (Contributor+) Arbitrary File Upload","id":"CVE-2024-6000"},"packages":[{"ecosystem":"PyPI","fixed":["0.2.9"],"introduced":["0"],"last_affected":[],"package":"langchain","purl":"pkg:pypi/langchain","source":"PYSEC-2024-323"},{"ecosystem":"PyPI","fixed":["0.2.4"],"introduced":["0"],"last_affected":[],"package":"langchain-community","purl":null,"source":"GHSA-f2jm-rw3h-6phg"},{"ecosystem":"PyPI","fixed":["0.2.4"],"introduced":["0"],"last_affected":[],"package":"langchain-community","purl":"pkg:pypi/langchain-community","source":"GHSA-f2jm-rw3h-6phg"},{"ecosystem":"PyPI","fixed":["0.2.4"],"introduced":["0"],"last_affected":[],"package":"langchain-community","purl":"pkg:pypi/langchain-community","source":"PYSEC-2026-1514"}],"prev":{"headline":"Duplica \u003c= 0.6 - Authenticated (Subscriber+) Missing Authorization to Users/Posts Duplicates Creation","id":"CVE-2024-5997"},"products":["langchain-ai/langchain"],"published":"2024-09-17","related":[{"cvss_score":9.8,"headline":"Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library","id":"CVE-2023-39631","kev_date_added":null,"published":"2023-09-01"},{"cvss_score":9.8,"headline":"langchain vulnerable to arbitrary code execution","id":"CVE-2023-36281","kev_date_added":null,"published":"2023-08-22"},{"cvss_score":9.8,"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-38860","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":9.8,"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-38896","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":9.8,"headline":"LangChain vulnerable to arbitrary code execution","id":"CVE-2023-39659","kev_date_added":null,"published":"2023-08-15"},{"cvss_score":9.8,"headline":"langchain Code Injection vulnerability","id":"CVE-2023-36095","kev_date_added":null,"published":"2023-08-05"},{"cvss_score":9.8,"headline":"langchain vulnerable to arbitrary code execution","id":"CVE-2023-36188","kev_date_added":null,"published":"2023-07-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-17","vendors":["langchain-ai"]},"summary":"Attackers can execute arbitrary commands via unsafe pickle deserialization in the FAISS module of the LangChain library.","url":"https://insights.sbomify.com/CVE-2024-5998/"}