# CVE-2024-5998: Deserialization of Untrusted Data in langchain-ai/langchain

> Attackers can execute arbitrary commands via unsafe pickle deserialization in the FAISS module of the LangChain library.

- **Severity:** Medium 5.2 (`CVSS:3.0/AV:P/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Sep 2024
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-f2jm-rw3h-6phg, PYSEC-2024-323, PYSEC-2026-1514

## What is CVE-2024-5998?

CVE-2024-5998 is a medium-severity unsafe deserialization vulnerability in langchain-ai/langchain, published on 17 Sep 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A vulnerability in the FAISS.deserialize_from_bytes function of langchain-ai/langchain allows for pickle deserialization of untrusted data. This can lead to the execution of arbitrary commands via the os.system function. The issue affects the latest version of the product.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2024-5998?

4 open source packages ship an affected version, including langchain-community and langchain. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langchain-community` | PyPI | All versions | 0.2.4 |
| `langchain-community` | PyPI | All versions | 0.2.4 |
| `langchain-community` | PyPI | All versions | 0.2.4 |
| `langchain` | PyPI | All versions | 0.2.9 |

Products: Langchain Langchain.

## How do I fix CVE-2024-5998?

Upgrade langchain-community to 0.2.4 or later.

## Is CVE-2024-5998 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5998 exists.

## Other vulnerabilities in langchain-ai/langchain

- [CVE-2023-39631](https://insights.sbomify.com/CVE-2023-39631/): Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library (critical 9.8)
- [CVE-2023-36281](https://insights.sbomify.com/CVE-2023-36281/): langchain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38860](https://insights.sbomify.com/CVE-2023-38860/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-38896](https://insights.sbomify.com/CVE-2023-38896/): LangChain vulnerable to arbitrary code execution (critical 9.8)
- [CVE-2023-39659](https://insights.sbomify.com/CVE-2023-39659/): LangChain vulnerable to arbitrary code execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-5998 and fix it if it is affected.

What it is: CVE-2024-5998 is a medium-severity unsafe deserialization vulnerability in langchain-ai/langchain, published on 17 Sep 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-5998 exists.

Affected packages and fixed versions:
- langchain-community (PyPI): affected all versions; fixed in 0.2.4
- langchain-community (PyPI): affected all versions; fixed in 0.2.4
- langchain-community (PyPI): affected all versions; fixed in 0.2.4
- langchain (PyPI): affected all versions; fixed in 0.2.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-5998/ (Markdown: https://insights.sbomify.com/CVE-2024-5998/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-5998
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-5998
- OSV: https://osv.dev/vulnerability/CVE-2024-5998

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-5998/
Summaries are generated and may contain mistakes; the official description above is the record.
