# CVE-2024-6010: Cost Calculator Builder PRO <= 3.2.1 - Unauthenticated Price Manipulation

> Unauthenticated attackers can manipulate order prices in Cost Calculator Builder PRO due to insufficient validation of price fields.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Sep 2024
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-xrp5-mffj-h7gr

## What is CVE-2024-6010?

CVE-2024-6010 is a medium-severity vulnerability in StylemixThemes Cost Calculator Builder PRO, published on 7 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Cost Calculator Builder PRO plugin for WordPress is vulnerable to price manipulation in all versions up to, and including, 3.2.1. This is due to the plugin allowing the price field to be manipulated prior to processing via the 'create_cc_order' function, called from the Cost Calculator Builder plugin. This makes it possible for unauthenticated attackers to manipulate the price of orders submitted via the calculator. Note: this vulnerability was partially patched with the release of Cost Calculator Builder version 3.2.17.

Weakness: CWE-472 (External Control of Assumed-Immutable Web Parameter)

## Which versions are affected by CVE-2024-6010?

It affects 1 product.


Products: Stylemixthemes Cost Calculator Builder.

## How do I fix CVE-2024-6010?

No fix has been published for CVE-2024-6010 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-6010 being exploited?

There is no known exploitation of CVE-2024-6010 in the wild and no public exploit code.

## Other vulnerabilities in StylemixThemes Cost Calculator Builder PRO

- [CVE-2024-43144](https://insights.sbomify.com/CVE-2024-43144/): WordPress Cost Calculator Builder plugin <= 3.2.15 - SQL Injection vulnerability (critical 9.3)
- [CVE-2024-8379](https://insights.sbomify.com/CVE-2024-8379/): Cost Calculator Builder < 3.2.29 - Admin+ SQL Injection (high 7.2)
- [CVE-2024-10892](https://insights.sbomify.com/CVE-2024-10892/): Cost Calculator Builder < 3.2.43 - Settings update via CSRF (medium 5.4)
- [CVE-2025-14757](https://insights.sbomify.com/CVE-2025-14757/): Cost Calculator Builder <= 3.6.9 - Missing Authorization to Unauthenticated Payment Status Bypass (medium 5.3)
- [CVE-2024-6011](https://insights.sbomify.com/CVE-2024-6011/): Cost Calculator Builder <= 3.2.12 - Authenticated (Administrator+) Stored Cross-Site Scripting (medium 4.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-6010 and fix it if it is affected.

What it is: CVE-2024-6010 is a medium-severity vulnerability in StylemixThemes Cost Calculator Builder PRO, published on 7 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-6010 in the wild and no public exploit code.

Affected product: StylemixThemes Cost Calculator Builder PRO. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-6010/ (Markdown: https://insights.sbomify.com/CVE-2024-6010/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-6010
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-6010
- OSV: https://osv.dev/vulnerability/CVE-2024-6010

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-6010/
Summaries are generated and may contain mistakes; the official description above is the record.
