CVE-2024-6155 Server-side request forgery in Greenshift – animation and page builder blocks
Authenticated attackers can exploit missing authorization to perform SSRF and inject stored XSS via SVG uploads, potentially accessing cloud metadata.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2024-6155?
CVE-2024-6155 is a medium-severity server-side request forgery vulnerability in wpsoul Greenshift – animation and page builder blocks, published on 9 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to Authenticated (Subscriber+) Server-Side Request Forgery and Stored Cross Site Scripting in all versions up to, and including, 9.0.0 due to a missing capability check in the greenshift_download_file_localy function, along with no SSRF protection and sanitization on uploaded SVG files. This makes it possible for authenticated attackers, with Subscriber-level access and above, to make web requests to arbitrary locations originating from the web application that can also be leveraged to download malicious SVG files containing Cross-Site Scripting payloads to the server. On Cloud-based servers, attackers could retrieve the instance metadata. The issue was partially patched in version 8.9.9 and fully patched in version 9.0.1.
Which versions are affected by CVE-2024-6155?
It affects 1 product.
Products include Greenshiftwp Greenshift - Animation and Page Builder Blocks.
How do I fix CVE-2024-6155?
No fix has been published for CVE-2024-6155 yet. Limit exposure of the affected software until one is available.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2024-6155 being exploited?
There is no known exploitation of CVE-2024-6155 in the wild and no public exploit code.
Other vulnerabilities in wpsoul Greenshift – animation and page builder blocks
- CVE-2025-3616 Greenshift 11.4 - 11.4.5 - Authenticated (Subscriber+) Arbitrary File Upload
- CVE-2025-26884 WordPress Greenshift plugin <= 10.8 - Cross Site Scripting (XSS) vulnerability
- CVE-2024-50419 WordPress Greenshift plugin <=9.7 - Broken Access Control vulnerability
- CVE-2024-11181 Greenshift – animation and page builder blocks <= 9.9.9.3 - Authenticated (Contributor+) Post Disclosure
Sources
Also known as GHSA-m7jq-35x5-2p74.