# CVE-2024-6155: Server-side request forgery in Greenshift – animation and page builder blocks

> Authenticated attackers can exploit missing authorization to perform SSRF and inject stored XSS via SVG uploads, potentially accessing cloud metadata.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Jan 2025
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-m7jq-35x5-2p74

## What is CVE-2024-6155?

CVE-2024-6155 is a medium-severity server-side request forgery vulnerability in wpsoul Greenshift – animation and page builder blocks, published on 9 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to Authenticated (Subscriber+) Server-Side Request Forgery and Stored Cross Site Scripting in all versions up to, and including, 9.0.0 due to a missing capability check in the greenshift_download_file_localy function, along with no SSRF protection and sanitization on uploaded SVG files. This makes it possible for authenticated attackers, with Subscriber-level access and above, to make web requests to arbitrary locations originating from the web application that can also be leveraged to download malicious SVG files containing Cross-Site Scripting payloads to the server. On Cloud-based servers, attackers could retrieve the instance metadata. The issue was partially patched in version 8.9.9 and fully patched in version 9.0.1.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2024-6155?

It affects 1 product.


Products: Greenshiftwp Greenshift - Animation and Page Builder Blocks.

## How do I fix CVE-2024-6155?

No fix has been published for CVE-2024-6155 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-6155 being exploited?

There is no known exploitation of CVE-2024-6155 in the wild and no public exploit code.

## Other vulnerabilities in wpsoul Greenshift – animation and page builder blocks

- [CVE-2025-3616](https://insights.sbomify.com/CVE-2025-3616/): Greenshift 11.4 - 11.4.5 - Authenticated (Subscriber+) Arbitrary File Upload (high 8.8)
- [CVE-2025-26884](https://insights.sbomify.com/CVE-2025-26884/): WordPress Greenshift plugin <= 10.8 - Cross Site Scripting (XSS) vulnerability (medium 6.5)
- [CVE-2024-50419](https://insights.sbomify.com/CVE-2024-50419/): WordPress Greenshift plugin <=9.7 - Broken Access Control vulnerability (medium 5.4)
- [CVE-2024-11181](https://insights.sbomify.com/CVE-2024-11181/): Greenshift – animation and page builder blocks <= 9.9.9.3 - Authenticated (Contributor+) Post Disclosure (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-6155 and fix it if it is affected.

What it is: CVE-2024-6155 is a medium-severity server-side request forgery vulnerability in wpsoul Greenshift – animation and page builder blocks, published on 9 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-6155 in the wild and no public exploit code.

Affected product: wpsoul Greenshift – animation and page builder blocks. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-6155/ (Markdown: https://insights.sbomify.com/CVE-2024-6155/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-6155
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-6155
- OSV: https://osv.dev/vulnerability/CVE-2024-6155

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-6155/
Summaries are generated and may contain mistakes; the official description above is the record.
