# CVE-2024-6221: Improper Access Control in corydolphin/flask-cors

> The library defaults to allowing private network access via CORS, exposing internal resources to external attackers for data theft or network intrusion.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Aug 2024
- **Updated:** 7 Apr 2025
- **Also known as:** DEBIAN-CVE-2024-6221, GHSA-hxwh-jpp2-84pm, OESA-2024-2198, PYSEC-2024-71, ROOT-APP-PYPI-CVE-2024-6221, UBUNTU-CVE-2024-6221

## What is CVE-2024-6221?

CVE-2024-6221 is a medium-severity vulnerability in corydolphin/flask-cors, published on 18 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability in corydolphin/flask-cors version 4.0.1 allows the `Access-Control-Allow-Private-Network` CORS header to be set to true by default. This behavior can expose private network resources to unauthorized external access, leading to significant security risks such as data breaches, unauthorized access to sensitive information, and potential network intrusions.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2024-6221?

3 open source packages ship an affected version, including flask-cors and Flask-Cors. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flask-cors` | PyPI | All versions | 4.0.2 |
| `flask-cors` | PyPI | All versions | 4.0.2 |
| `Flask-Cors` | PyPI | All versions | 4.0.2 |

Products: Corydolphin Flask-Cors.

## How do I fix CVE-2024-6221?

Upgrade flask-cors to 4.0.2 or later.

## Is CVE-2024-6221 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6221 exists.

## Other vulnerabilities in corydolphin/flask-cors

- [CVE-2024-1681](https://insights.sbomify.com/CVE-2024-1681/): Log Injection Vulnerability in corydolphin/flask-cors (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-6221 and fix it if it is affected.

What it is: CVE-2024-6221 is a medium-severity vulnerability in corydolphin/flask-cors, published on 18 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6221 exists.

Affected packages and fixed versions:
- flask-cors (PyPI): affected all versions; fixed in 4.0.2
- flask-cors (PyPI): affected all versions; fixed in 4.0.2
- Flask-Cors (PyPI): affected all versions; fixed in 4.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-6221/ (Markdown: https://insights.sbomify.com/CVE-2024-6221/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-6221
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-6221
- OSV: https://osv.dev/vulnerability/CVE-2024-6221

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-6221/
Summaries are generated and may contain mistakes; the official description above is the record.
