{"answers":{"affected":"3 open source packages ship an affected version, including lollms.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6281 exists.","fix":"Upgrade lollms to 9.5.1 or later.","what":"CVE-2024-6281 is a high-severity path traversal vulnerability in parisneo/lollms, published on 20 Jul 2024. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-6281 and fix it if it is affected.\n\nWhat it is: CVE-2024-6281 is a high-severity path traversal vulnerability in parisneo/lollms, published on 20 Jul 2024. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6281 exists.\n\nAffected packages and fixed versions:\n- lollms (PyPI): affected all versions; fixed in 9.5.1\n- lollms (PyPI): affected all versions; fixed in 9.5.1\n- lollms (PyPI): affected all versions; fixed in 9.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-6281/ (Markdown: https://insights.sbomify.com/CVE-2024-6281/index.md)","id":"CVE-2024-6281","markdown":"https://insights.sbomify.com/CVE-2024-6281/index.md","name":"CVE-2024-6281","record":{"aliases":["GHSA-8mrm-r7h3-c3hj","PYSEC-2026-1587"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python LLM library","requires_auth":"none","summary":"Attackers can exploit a path traversal flaw in the apply_settings function to write files to arbitrary system locations.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H","version":"3.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"A path traversal vulnerability exists in the `apply_settings` function of parisneo/lollms versions prior to 9.5.1. The `sanitize_path` function does not adequately secure the `discussion_db_name` parameter, allowing attackers to manipulate the path and potentially write to important system folders.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Path Traversal in parisneo/lollms","id":"CVE-2024-6281","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Cross-site scripting in Master Addons For Elementor – Widgets, Extensions, Theme Builder, Popup Builder \u0026 Template Kits","id":"CVE-2024-6282"},"packages":[{"ecosystem":"PyPI","fixed":["9.5.1"],"introduced":["0"],"last_affected":[],"package":"lollms","purl":null,"source":"GHSA-8mrm-r7h3-c3hj"},{"ecosystem":"PyPI","fixed":["9.5.1"],"introduced":["0"],"last_affected":[],"package":"lollms","purl":"pkg:pypi/lollms","source":"GHSA-8mrm-r7h3-c3hj"},{"ecosystem":"PyPI","fixed":["9.5.1"],"introduced":["0"],"last_affected":[],"package":"lollms","purl":"pkg:pypi/lollms","source":"PYSEC-2026-1587"}],"prev":{"headline":"SourceCodester Simple Online Bidding System unrestricted upload","id":"CVE-2024-6280"},"products":["parisneo/lollms"],"published":"2024-07-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-15","vendors":["parisneo"]},"summary":"Attackers can exploit a path traversal flaw in the apply_settings function to write files to arbitrary system locations.","url":"https://insights.sbomify.com/CVE-2024-6281/"}