# CVE-2024-6281: Path Traversal in parisneo/lollms

> Attackers can exploit a path traversal flaw in the apply_settings function to write files to arbitrary system locations.

- **Severity:** High 7.3 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2024
- **Updated:** 15 Oct 2025
- **Also known as:** GHSA-8mrm-r7h3-c3hj, PYSEC-2026-1587

## What is CVE-2024-6281?

CVE-2024-6281 is a high-severity path traversal vulnerability in parisneo/lollms, published on 20 Jul 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A path traversal vulnerability exists in the `apply_settings` function of parisneo/lollms versions prior to 9.5.1. The `sanitize_path` function does not adequately secure the `discussion_db_name` parameter, allowing attackers to manipulate the path and potentially write to important system folders.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-6281?

3 open source packages ship an affected version, including lollms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lollms` | PyPI | All versions | 9.5.1 |
| `lollms` | PyPI | All versions | 9.5.1 |
| `lollms` | PyPI | All versions | 9.5.1 |

## How do I fix CVE-2024-6281?

Upgrade lollms to 9.5.1 or later.

## Is CVE-2024-6281 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6281 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-6281 and fix it if it is affected.

What it is: CVE-2024-6281 is a high-severity path traversal vulnerability in parisneo/lollms, published on 20 Jul 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6281 exists.

Affected packages and fixed versions:
- lollms (PyPI): affected all versions; fixed in 9.5.1
- lollms (PyPI): affected all versions; fixed in 9.5.1
- lollms (PyPI): affected all versions; fixed in 9.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-6281/ (Markdown: https://insights.sbomify.com/CVE-2024-6281/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-6281
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-6281
- OSV: https://osv.dev/vulnerability/CVE-2024-6281

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-6281/
Summaries are generated and may contain mistakes; the official description above is the record.
