{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite.","exploited":"There is no known exploitation of CVE-2024-6307 in the wild and no public exploit code.","fix":"Upgrade wordpress to a fixed version for your release line: 5.9.10, 6.0.9, 6.1.7 or 6.2.5.","what":"CVE-2024-6307 is a medium-severity cross-site scripting vulnerability in WordPress, published on 25 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-6307 and fix it if it is affected.\n\nWhat it is: CVE-2024-6307 is a medium-severity cross-site scripting vulnerability in WordPress, published on 25 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-6307 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected from 5.9.0; fixed in 5.9.10, 6.0.9, 6.1.7, 6.2.5, 6.3.5, 6.4.5, 6.5.5\n- wordpress-multisite (Bitnami): affected from 5.9.0; fixed in 5.9.10, 6.0.9, 6.1.7, 6.2.5, 6.3.5, 6.4.5, 6.5.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-6307/ (Markdown: https://insights.sbomify.com/CVE-2024-6307/index.md)","id":"CVE-2024-6307","markdown":"https://insights.sbomify.com/CVE-2024-6307/index.md","name":"CVE-2024-6307","record":{"aliases":["BIT-wordpress-2024-6307","BIT-wordpress-multisite-2024-6307","DEBIAN-CVE-2024-6307","GHSA-2f47-vffr-pwwf","UBUNTU-CVE-2024-6307"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress Core","requires_auth":"low_privilege","summary":"Authenticated contributors can inject arbitrary scripts via the HTML API, leading to code execution or account takeover when pages are viewed.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[],"description":"WordPress Core is vulnerable to Stored Cross-Site Scripting via the HTML API in various versions prior to 6.5.5 due to insufficient input sanitization and output escaping on URLs. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WordPress Core \u003c 6.5.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via HTML API","id":"CVE-2024-6307","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":4,"next":{"headline":"itsourcecode Simple Online Hotel Reservation System index.php sql injection","id":"CVE-2024-6308"},"packages":[{"ecosystem":"Bitnami","fixed":["5.9.10","6.0.9","6.1.7","6.2.5","6.3.5","6.4.5","6.5.5"],"introduced":["5.9.0","6.0.0","6.1.0","6.2.0","6.3.0","6.4.0","6.5.0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2024-6307"},{"ecosystem":"Bitnami","fixed":["5.9.10","6.0.9","6.1.7","6.2.5","6.3.5","6.4.5","6.5.5"],"introduced":["5.9.0","6.0.0","6.1.0","6.2.0","6.3.0","6.4.0","6.5.0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2024-6307"}],"prev":{"headline":"**REJECT** Accidental Reservation making this a duplicate.","id":"CVE-2024-6306"},"products":["WordPress"],"published":"2024-06-25","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["WordPress Foundation"]},"summary":"Authenticated contributors can inject arbitrary scripts via the HTML API, leading to code execution or account takeover when pages are viewed.","url":"https://insights.sbomify.com/CVE-2024-6307/"}