# CVE-2024-6307: WordPress Core < 6.5.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via HTML API

> Authenticated contributors can inject arbitrary scripts via the HTML API, leading to code execution or account takeover when pages are viewed.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jun 2024
- **Updated:** 1 Aug 2024
- **Also known as:** BIT-wordpress-2024-6307, BIT-wordpress-multisite-2024-6307, DEBIAN-CVE-2024-6307, GHSA-2f47-vffr-pwwf, UBUNTU-CVE-2024-6307

## What is CVE-2024-6307?

CVE-2024-6307 is a medium-severity cross-site scripting vulnerability in WordPress, published on 25 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

WordPress Core is vulnerable to Stored Cross-Site Scripting via the HTML API in various versions prior to 6.5.5 due to insufficient input sanitization and output escaping on URLs. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

## Which versions are affected by CVE-2024-6307?

2 open source packages ship an affected version, including wordpress and wordpress-multisite.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordpress` | Bitnami | From 5.9.0 | 5.9.10, 6.0.9, 6.1.7, 6.2.5, 6.3.5, 6.4.5, 6.5.5 |
| `wordpress-multisite` | Bitnami | From 5.9.0 | 5.9.10, 6.0.9, 6.1.7, 6.2.5, 6.3.5, 6.4.5, 6.5.5 |

## How do I fix CVE-2024-6307?

Upgrade wordpress to a fixed version for your release line: 5.9.10, 6.0.9, 6.1.7 or 6.2.5.

## Is CVE-2024-6307 being exploited?

There is no known exploitation of CVE-2024-6307 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-6307 and fix it if it is affected.

What it is: CVE-2024-6307 is a medium-severity cross-site scripting vulnerability in WordPress, published on 25 Jun 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-6307 in the wild and no public exploit code.

Affected packages and fixed versions:
- wordpress (Bitnami): affected from 5.9.0; fixed in 5.9.10, 6.0.9, 6.1.7, 6.2.5, 6.3.5, 6.4.5, 6.5.5
- wordpress-multisite (Bitnami): affected from 5.9.0; fixed in 5.9.10, 6.0.9, 6.1.7, 6.2.5, 6.3.5, 6.4.5, 6.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-6307/ (Markdown: https://insights.sbomify.com/CVE-2024-6307/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-6307
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-6307
- OSV: https://osv.dev/vulnerability/CVE-2024-6307

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-6307/
Summaries are generated and may contain mistakes; the official description above is the record.
