CVE-2024-6323 Improper Isolation or Compartmentalization in GitLab

High 7.5 Published Updated

An attacker can leak content from private repositories in public projects via improper authorization in global search.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-6323?

CVE-2024-6323 is a high-severity missing authorization vulnerability in Gitlab Gitlab, published on 26 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Improper authorization in global search in GitLab EE affecting all versions from 16.11 prior to 16.11.5 and 17.0 prior to 17.0.3 and 17.1 prior to 17.1.1 allows an attacker leak content of a private repository in a public project.

Weakness: CWE-863

Which versions are affected by CVE-2024-6323?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 16.11.016.11.5, 17.0.3, 17.1.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-6323?

Upgrade gitlab to a fixed version for your release line: 16.11.5, 17.0.3 or 17.1.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2024-6323 being exploited?

There is no known exploitation of CVE-2024-6323 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-6323, GHSA-chjh-944f-687f.

Is CVE-2024-6323 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free