CVE-2024-6329 Improper Encoding or Escaping of Output in GitLab

Medium 5.7 Published Updated

Attackers can execute arbitrary scripts in the GitLab web interface by exploiting improper output encoding in diff rendering.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-6329?

CVE-2024-6329 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 8 Aug 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue was discovered in GitLab CE/EE affecting all versions starting from 8.16 prior to 17.0.6, starting from 17.1 prior to 17.1.4, and starting from 17.2 prior to 17.2.2, which causes the web interface to fail to render the diff correctly when the path is encoded.

Weakness: CWE-116

Which versions are affected by CVE-2024-6329?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 8.16.017.0.6, 17.1.4, 17.2.2

Products include Gitlab Gitlab.

How do I fix CVE-2024-6329?

Upgrade gitlab to a fixed version for your release line: 17.0.6, 17.1.4 or 17.2.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-6329 being exploited?

There is no known exploitation of CVE-2024-6329 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-6329, GHSA-vr5w-hwpc-cjqr, UBUNTU-CVE-2024-6329.

Is CVE-2024-6329 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free