# CVE-2024-6329: Improper Encoding or Escaping of Output in GitLab

> Attackers can execute arbitrary scripts in the GitLab web interface by exploiting improper output encoding in diff rendering.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Aug 2024
- **Updated:** 29 Aug 2024
- **Also known as:** BIT-gitlab-2024-6329, GHSA-vr5w-hwpc-cjqr, UBUNTU-CVE-2024-6329

## What is CVE-2024-6329?

CVE-2024-6329 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 8 Aug 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

An issue was discovered in GitLab CE/EE affecting all versions starting from 8.16 prior to 17.0.6, starting from 17.1 prior to 17.1.4, and starting from 17.2 prior to 17.2.2, which causes the web interface to fail to render the diff correctly when the path is encoded.

Weakness: CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2024-6329?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 8.16.0 | 17.0.6, 17.1.4, 17.2.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2024-6329?

Upgrade gitlab to a fixed version for your release line: 17.0.6, 17.1.4 or 17.2.2.

## Is CVE-2024-6329 being exploited?

There is no known exploitation of CVE-2024-6329 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-6329 and fix it if it is affected.

What it is: CVE-2024-6329 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 8 Aug 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-6329 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 8.16.0; fixed in 17.0.6, 17.1.4, 17.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-6329/ (Markdown: https://insights.sbomify.com/CVE-2024-6329/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-6329
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-6329
- OSV: https://osv.dev/vulnerability/CVE-2024-6329

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-6329/
Summaries are generated and may contain mistakes; the official description above is the record.
