CVE-2024-6340 Premium Addons for Elementor <= 4.10.36 - Authenticated (Contributor+) Stored Cross-Site Scripting via Countdown Widget
Authenticated contributors can inject arbitrary scripts via the Countdown widget, leading to stored XSS execution for other users.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2024-6340?
CVE-2024-6340 is a medium-severity cross-site scripting vulnerability in leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets, published on 3 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The Premium Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's Countdown widget in all versions up to, and including, 4.10.36 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 4.10.36 and fully patched in version 4.10.37.
Weakness: CWE-79
Which versions are affected by CVE-2024-6340?
It affects 1 product.
Products include Leap13 Premium Addons for Elementor.
How do I fix CVE-2024-6340?
No fix has been published for CVE-2024-6340 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-6340 being exploited?
There is no known exploitation of CVE-2024-6340 in the wild and no public exploit code.
Other vulnerabilities in leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets
- CVE-2023-34012 WordPress Premium Addons PRO Plugin <= 2.8.24 is vulnerable to Cross Site Scripting (XSS)
- CVE-2021-4445 Premium Addons for Elementor <= 4.5.1 - Authenticated (Subscriber+) Limited Arbitrary Option Update
- CVE-2024-37922 WordPress Premium Addons for Elementor plugin <= 4.10.34 - Cross Site Scripting (XSS) vulnerability
- CVE-2024-32791 WordPress Premium Addons for Elementor plugin <= 4.10.25 - Cross Site Scripting (XSS) vulnerability
- CVE-2024-29106 WordPress Premium Addons for Elementor plugin <= 4.10.16 - Cross Site Scripting (XSS) vulnerability
Sources
Also known as GHSA-qqg3-wxg7-6j3v.