# CVE-2024-6376: ejson shell parser in MongoDB Compass maybe bypassed

> Attackers can execute arbitrary code via the ejson shell parser in MongoDB Compass due to insufficient sandbox protection.

- **Severity:** High 7.0 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Jul 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-jxr4-4prv-mh83

## What is CVE-2024-6376?

CVE-2024-6376 is a high-severity code injection vulnerability in MongoDB Compass, published on 1 Jul 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

MongoDB Compass may be susceptible to code injection due to insufficient sandbox protection settings with the usage of ejson shell parser in Compass' connection handling. This issue affects MongoDB Compass versions prior to version 1.42.2

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2024-6376?

2 open source packages ship an affected version, including @mongodb-js/connection-form. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@mongodb-js/connection-form` | npm | All versions | 1.20.1 |
| `@mongodb-js/connection-form` | npm | All versions | 1.20.1 |

Products: Mongodb Compass.

## How do I fix CVE-2024-6376?

Upgrade @mongodb-js/connection-form to 1.20.1 or later.

## Is CVE-2024-6376 being exploited?

There is no known exploitation of CVE-2024-6376 in the wild and no public exploit code.

## Other vulnerabilities in MongoDB Compass

- [CVE-2026-14881](https://insights.sbomify.com/CVE-2026-14881/): Command injection in MongoDB Compass (high 8.4)
- [CVE-2025-1755](https://insights.sbomify.com/CVE-2025-1755/): MongoDB Compass may be susceptible to local privilege escalation in Windows (high 7.5)
- [CVE-2024-3371](https://insights.sbomify.com/CVE-2024-3371/): Insufficient validation of external input in Compass may enable MITM attacks (high 7.1)
- [CVE-2026-9101](https://insights.sbomify.com/CVE-2026-9101/): Prototype pollution in csv parsing (medium 5.3)
- [CVE-2021-20334](https://insights.sbomify.com/CVE-2021-20334/): Local privilege escalation in MongoDB Compass for Windows (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-6376 and fix it if it is affected.

What it is: CVE-2024-6376 is a high-severity code injection vulnerability in MongoDB Compass, published on 1 Jul 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-6376 in the wild and no public exploit code.

Affected packages and fixed versions:
- @mongodb-js/connection-form (npm): affected all versions; fixed in 1.20.1
- @mongodb-js/connection-form (npm): affected all versions; fixed in 1.20.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-6376/ (Markdown: https://insights.sbomify.com/CVE-2024-6376/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-6376
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-6376
- OSV: https://osv.dev/vulnerability/CVE-2024-6376

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-6376/
Summaries are generated and may contain mistakes; the official description above is the record.
