# CVE-2024-6384: Backup files may be downloaded by underprivileged users in MongoDB Enterprise Server

> Underprivileged users can download hot backup files if they obtain a unique identifier, leading to unauthorized data disclosure.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2024
- **Updated:** 15 Nov 2024
- **Also known as:** BIT-mongodb-2024-6384, GHSA-gvrf-4h52-xwxp

## What is CVE-2024-6384?

CVE-2024-6384 is a medium-severity missing authorization vulnerability in Mongodb Mongodb, published on 13 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

"Hot" backup files may be downloaded by underprivileged users, if they are capable of acquiring a unique backup identifier. This issue affects MongoDB Enterprise Server v6.0 versions prior to 6.0.16, MongoDB Enterprise Server v7.0 versions prior to 7.0.11 and MongoDB Enterprise Server v7.3 versions prior to 7.3.3

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2024-6384?

1 open source package ship an affected version, including mongodb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mongodb` | Bitnami | From 6.0.0 | 6.0.16, 7.0.11, 7.3.3 |

Products: Mongodb Mongodb.

## How do I fix CVE-2024-6384?

Upgrade mongodb to a fixed version for your release line: 6.0.16, 7.0.11 or 7.3.3.

## Is CVE-2024-6384 being exploited?

There is no known exploitation of CVE-2024-6384 in the wild and no public exploit code.

## Other vulnerabilities in Mongodb Mongodb

- [CVE-2025-14847](https://insights.sbomify.com/CVE-2025-14847/): MongoDB and MongoDB Server Improper Handling of Length Parameter Inconsistency (high 8.7, exploited in the wild)
- [CVE-2026-82067](https://insights.sbomify.com/CVE-2026-82067/): Auth bypass in MongoDB Server (critical 9.2)
- [CVE-2026-13072](https://insights.sbomify.com/CVE-2026-13072/): MongoDB Improper Input Validation in Compute Mode External Data Processing Leading to Memory Corruption (critical 9.2)
- [CVE-2017-15535](https://insights.sbomify.com/CVE-2017-15535/): Denial of service in n/a (critical 9.1)
- [CVE-2026-18691](https://insights.sbomify.com/CVE-2026-18691/): Improper Authentication in MongoDB Intra-Cluster Connections Allows Credential Exposure (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-6384 and fix it if it is affected.

What it is: CVE-2024-6384 is a medium-severity missing authorization vulnerability in Mongodb Mongodb, published on 13 Aug 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-6384 in the wild and no public exploit code.

Affected packages and fixed versions:
- mongodb (Bitnami): affected from 6.0.0; fixed in 6.0.16, 7.0.11, 7.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-6384/ (Markdown: https://insights.sbomify.com/CVE-2024-6384/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-6384
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-6384
- OSV: https://osv.dev/vulnerability/CVE-2024-6384

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-6384/
Summaries are generated and may contain mistakes; the official description above is the record.
