CVE-2024-6385 Improper Access Control in GitLab
An attacker can trigger CI/CD pipelines as another user, potentially leading to privilege escalation and code execution in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-6385?
CVE-2024-6385 is a critical missing authorization vulnerability in Gitlab Gitlab, published on 11 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in GitLab CE/EE affecting all versions starting from 15.8 prior to 16.11.6, starting from 17.0 prior to 17.0.4, and starting from 17.1 prior to 17.1.2, which allows an attacker to trigger a pipeline as another user under certain circumstances.
Weakness: CWE-284
Which versions are affected by CVE-2024-6385?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 15.8.0 | 16.11.6, 17.0.4, 17.1.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-6385?
Upgrade gitlab to a fixed version for your release line: 16.11.6, 17.0.4 or 17.1.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-6385 being exploited?
There is no known exploitation of CVE-2024-6385 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-6385, GHSA-74cm-4qqj-22p4.