# CVE-2024-6411: Privilege escalation in ProfileGrid – User Profiles, Groups and Communities

> Authenticated subscribers can escalate privileges to Administrator via improper validation in the ProfileGrid WordPress plugin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Jul 2024
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-wgp4-g5wv-7wf9

## What is CVE-2024-6411?

CVE-2024-6411 is a high-severity vulnerability in metagauss ProfileGrid – User Profiles, Groups and Communities, published on 10 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The ProfileGrid – User Profiles, Groups and Communities plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 5.8.9. This is due to a lack of validation on user-supplied data in the 'pm_upload_image' AJAX action. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update their user capabilities to Administrator.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2024-6411?

It affects 1 product.


Products: Metagauss Profilegrid.

## How do I fix CVE-2024-6411?

No fix has been published for CVE-2024-6411 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-6411 being exploited?

There is no known exploitation of CVE-2024-6411 in the wild and no public exploit code.

## Other vulnerabilities in metagauss ProfileGrid – User Profiles, Groups and Communities

- [CVE-2024-30490](https://insights.sbomify.com/CVE-2024-30490/): WordPress ProfileGrid plugin <= 5.7.8 - SQL Injection vulnerability (critical 9.3)
- [CVE-2025-0724](https://insights.sbomify.com/CVE-2025-0724/): ProfileGrid – User Profiles, Groups and Communities <= 5.9.4.5 - Authenticated (Subscriber+) PHP Object Injection (high 8.8)
- [CVE-2023-3713](https://insights.sbomify.com/CVE-2023-3713/): ProfileGrid <= 5.5.1 - Authenticated (Subscriber+) Arbitrary Option Update (high 8.8)
- [CVE-2023-0940](https://insights.sbomify.com/CVE-2023-0940/): ProfileGrid < 5.3.1 - Subscriber+ Arbitrary Password Reset (high 8.8)
- [CVE-2019-15873](https://insights.sbomify.com/CVE-2019-15873/): Code injection in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-6411 and fix it if it is affected.

What it is: CVE-2024-6411 is a high-severity vulnerability in metagauss ProfileGrid – User Profiles, Groups and Communities, published on 10 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-6411 in the wild and no public exploit code.

Affected product: metagauss ProfileGrid – User Profiles, Groups and Communities. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-6411/ (Markdown: https://insights.sbomify.com/CVE-2024-6411/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-6411
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-6411
- OSV: https://osv.dev/vulnerability/CVE-2024-6411

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-6411/
Summaries are generated and may contain mistakes; the official description above is the record.
