# CVE-2024-6429: Content Spoofing in Multiple WSO2 Products via Error Message Injection

> Attackers can inject arbitrary content into UI error messages via URL parameters, enabling social engineering attacks in WSO2 products.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Sep 2025
- **Updated:** 25 Sep 2025
- **Also known as:** GHSA-r6f3-55wj-g9p3

## What is CVE-2024-6429?

CVE-2024-6429 is a medium-severity cross-site scripting vulnerability in Wso2 Api Manager, published on 23 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A content spoofing vulnerability exists in multiple WSO2 products due to improper error message handling. Under certain conditions, error messages are passed through URL parameters without validation, allowing malicious actors to inject arbitrary content into the UI.

By exploiting this vulnerability, attackers can manipulate browser-displayed error messages, enabling social engineering attacks through deceptive or misleading content.

Weakness: CWE-451 (User Interface (UI) Misrepresentation of Critical Information)

## Which versions are affected by CVE-2024-6429?

2 open source packages ship an affected version, including org.wso2.identity.apps:authentication-portal. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.wso2.identity.apps:authentication-portal` | Maven | All versions | 2.4.4 |
| `org.wso2.identity.apps:authentication-portal` | Maven | All versions | 2.4.4 |

Products: Wso2 Api Manager, Wso2 Identity Server.

## How do I fix CVE-2024-6429?

Upgrade org.wso2.identity.apps:authentication-portal to 2.4.4 or later.

## Is CVE-2024-6429 being exploited?

There is no known exploitation of CVE-2024-6429 in the wild and no public exploit code.

## Other vulnerabilities in Wso2 Api Manager

- [CVE-2022-29464](https://insights.sbomify.com/CVE-2022-29464/): WSO2 Multiple Products Unrestrictive Upload of File (critical 9.8, exploited in the wild)
- [CVE-2024-6914](https://insights.sbomify.com/CVE-2024-6914/): Incorrect Authorization in Multiple WSO2 Products via Account Recovery SOAP Admin Service Leading to Account Takeover (critical 9.8)
- [CVE-2020-13226](https://insights.sbomify.com/CVE-2020-13226/): WSO2 API Manager vulnerable to SSRF (critical 9.8)
- [CVE-2025-2905](https://insights.sbomify.com/CVE-2025-2905/): An XML External Entity (XXE) vulnerability in Multiple WSO2 Products (critical 9.1)
- [CVE-2021-42646](https://insights.sbomify.com/CVE-2021-42646/): XML external entity in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-6429 and fix it if it is affected.

What it is: CVE-2024-6429 is a medium-severity cross-site scripting vulnerability in Wso2 Api Manager, published on 23 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-6429 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.wso2.identity.apps:authentication-portal (Maven): affected all versions; fixed in 2.4.4
- org.wso2.identity.apps:authentication-portal (Maven): affected all versions; fixed in 2.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-6429/ (Markdown: https://insights.sbomify.com/CVE-2024-6429/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-6429
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-6429
- OSV: https://osv.dev/vulnerability/CVE-2024-6429

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-6429/
Summaries are generated and may contain mistakes; the official description above is the record.
