# CVE-2024-6434: Premium Addons for Elementor <= 4.10.35 - Regular Expressions Denial of Service

> Authenticated attackers can cause server resource exhaustion via malicious post titles in Premium Addons for Elementor.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 4 Jul 2024
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-w963-c33v-9fmc

## What is CVE-2024-6434?

CVE-2024-6434 is a low-severity denial of service vulnerability in leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets, published on 4 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Premium Addons for Elementor plugin for WordPress is vulnerable to Regular Expression Denial of Service (ReDoS) in all versions up to, and including, 4.10.35. This is due to processing user-supplied input as a regular expression. This makes it possible for authenticated attackers, with Author-level access and above, to create and query a malicious post title, resulting in slowing server resources.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-6434?

It affects 1 product.


Products: Leap13 Premium Addons for Elementor.

## How do I fix CVE-2024-6434?

No fix has been published for CVE-2024-6434 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-6434 being exploited?

There is no known exploitation of CVE-2024-6434 in the wild and no public exploit code.

## Other vulnerabilities in leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets

- [CVE-2023-34012](https://insights.sbomify.com/CVE-2023-34012/): WordPress Premium Addons PRO Plugin <= 2.8.24 is vulnerable to Cross Site Scripting (XSS) (high 7.1)
- [CVE-2021-4445](https://insights.sbomify.com/CVE-2021-4445/): Premium Addons for Elementor <= 4.5.1 - Authenticated (Subscriber+) Limited Arbitrary Option Update (medium 6.5)
- [CVE-2024-37922](https://insights.sbomify.com/CVE-2024-37922/): WordPress Premium Addons for Elementor plugin <= 4.10.34 - Cross Site Scripting (XSS) vulnerability (medium 6.5)
- [CVE-2024-32791](https://insights.sbomify.com/CVE-2024-32791/): WordPress Premium Addons for Elementor plugin <= 4.10.25 - Cross Site Scripting (XSS) vulnerability (medium 6.5)
- [CVE-2024-29106](https://insights.sbomify.com/CVE-2024-29106/): WordPress Premium Addons for Elementor plugin <= 4.10.16 - Cross Site Scripting (XSS) vulnerability (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-6434 and fix it if it is affected.

What it is: CVE-2024-6434 is a low-severity denial of service vulnerability in leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets, published on 4 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-6434 in the wild and no public exploit code.

Affected product: leap13 Premium Addons for Elementor – Powerful Elementor Templates & Widgets. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-6434/ (Markdown: https://insights.sbomify.com/CVE-2024-6434/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-6434
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-6434
- OSV: https://osv.dev/vulnerability/CVE-2024-6434

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-6434/
Summaries are generated and may contain mistakes; the official description above is the record.
