CVE-2024-6446 Business Logic Errors in GitLab

Low 3.5 Published Updated

Attackers can trick victims into trusting malicious applications via crafted URLs, requiring GitLab administrators to upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-6446?

CVE-2024-6446 is a low-severity vulnerability in Gitlab Gitlab, published on 12 Sep 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab affecting all versions starting from 17.1 to 17.1.7, 17.2 prior to 17.2.5 and 17.3 prior to 17.3.2. A crafted URL could be used to trick a victim to trust an attacker controlled application.

Weakness: CWE-840

Which versions are affected by CVE-2024-6446?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 17.1.017.1.7, 17.2.5, 17.3.2

Products include Gitlab Gitlab.

How do I fix CVE-2024-6446?

Upgrade gitlab to a fixed version for your release line: 17.1.7, 17.2.5 or 17.3.2.

Is CVE-2024-6446 being exploited?

There is no known exploitation of CVE-2024-6446 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-6446, GHSA-xh98-rwp8-8rpw, UBUNTU-CVE-2024-6446.

Is CVE-2024-6446 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free