CVE-2024-6468 Vault Vulnerable to Denial of Service When Setting a Proxy Protocol Behavior
Attackers can cause a denial of service in HashiCorp Vault by sending requests from unauthorized IPs when proxy protocol behavior is configured to deny unauthorized access.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-6468?
CVE-2024-6468 is a high-severity denial of service vulnerability in Hashicorp Vault, published on 11 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Vault and Vault Enterprise did not properly handle requests originating from unauthorized IP addresses when the TCP listener option, proxy_protocol_behavior, was set to deny_unauthorized. When receiving a request from a source IP address that was not listed in proxy_protocol_authorized_addrs, the Vault API server would shut down and no longer respond to any HTTP requests, potentially resulting in denial of service.
While this bug also affected versions of Vault up to 1.17.1 and 1.16.5, a separate regression in those release series did not allow Vault operators to configure the deny_unauthorized option, thus not allowing the conditions for the denial of service to occur.
Fixed in Vault and Vault Enterprise 1.17.2, 1.16.6, and 1.15.12.
Weakness: CWE-703
Which versions are affected by CVE-2024-6468?
8 open source packages ship an affected version, including github.com/hashicorp/vault and vault. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/hashicorp/vault Go | From 1.10.0 | 1.16.3, 1.17.2 |
github.com/hashicorp/vault Go | From 1.10.0 | 1.15.12 |
github.com/hashicorp/vault Go | From 1.10.0 | 1.15.12 |
github.com/hashicorp/vault Go | From 1.16.0-rc1 | 1.16.3 |
github.com/hashicorp/vault Go | From 1.16.0-rc1 | 1.16.3 |
github.com/hashicorp/vault Go | From 1.17.0-rc1 | 1.17.2 |
2 more packages
github.com/hashicorp/vault Go | From 1.17.0-rc1 | 1.17.2 |
vault Bitnami | From 1.10.0 | 1.16.3, 1.17.2 |
Products include Hashicorp Vault.
How do I fix CVE-2024-6468?
Upgrade github.com/hashicorp/vault to a fixed version for your release line: 1.16.3, 1.17.2 or 1.15.12.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2024-6468 being exploited?
There is no known exploitation of CVE-2024-6468 in the wild and no public exploit code.
Other vulnerabilities in Hashicorp Vault
Sources
Also known as BIT-vault-2024-6468, GHSA-2qmw-pvf7-4mw6, GO-2024-2982.