# CVE-2024-6468: Vault Vulnerable to Denial of Service When Setting a Proxy Protocol Behavior

> Attackers can cause a denial of service in HashiCorp Vault by sending requests from unauthorized IPs when proxy protocol behavior is configured to deny unauthorized access.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jul 2024
- **Updated:** 1 Aug 2024
- **Also known as:** BIT-vault-2024-6468, GHSA-2qmw-pvf7-4mw6, GO-2024-2982

## What is CVE-2024-6468?

CVE-2024-6468 is a high-severity denial of service vulnerability in Hashicorp Vault, published on 11 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Vault and Vault Enterprise did not properly handle requests originating from unauthorized IP addresses when the TCP listener option, proxy_protocol_behavior, was set to deny_unauthorized. When receiving a request from a source IP address that was not listed in proxy_protocol_authorized_addrs, the Vault API server would shut down and no longer respond to any HTTP requests, potentially resulting in denial of service.

While this bug also affected versions of Vault up to 1.17.1 and 1.16.5, a separate regression in those release series did not allow Vault operators to configure the deny_unauthorized option, thus not allowing the conditions for the denial of service to occur.

Fixed in Vault and Vault Enterprise 1.17.2, 1.16.6, and 1.15.12.

Weakness: CWE-703 (Improper Check or Handling of Exceptional Conditions)

## Which versions are affected by CVE-2024-6468?

8 open source packages ship an affected version, including github.com/hashicorp/vault and vault. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/vault` | Go | From 1.10.0 | 1.16.3, 1.17.2 |
| `github.com/hashicorp/vault` | Go | From 1.10.0 | 1.15.12 |
| `github.com/hashicorp/vault` | Go | From 1.10.0 | 1.15.12 |
| `github.com/hashicorp/vault` | Go | From 1.16.0-rc1 | 1.16.3 |
| `github.com/hashicorp/vault` | Go | From 1.16.0-rc1 | 1.16.3 |
| `github.com/hashicorp/vault` | Go | From 1.17.0-rc1 | 1.17.2 |
| `github.com/hashicorp/vault` | Go | From 1.17.0-rc1 | 1.17.2 |
| `vault` | Bitnami | From 1.10.0 | 1.16.3, 1.17.2 |

Products: Hashicorp Vault.

## How do I fix CVE-2024-6468?

Upgrade github.com/hashicorp/vault to a fixed version for your release line: 1.16.3, 1.17.2 or 1.15.12.

## Is CVE-2024-6468 being exploited?

There is no known exploitation of CVE-2024-6468 in the wild and no public exploit code.

## Other vulnerabilities in Hashicorp Vault

- [CVE-2020-35192](https://insights.sbomify.com/CVE-2020-35192/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-12757](https://insights.sbomify.com/CVE-2020-12757/): Improper Input Validation in HashiCorp Vault (critical 9.8)
- [CVE-2025-6000](https://insights.sbomify.com/CVE-2025-6000/): Arbitrary Remote Code Execution via Plugin Catalog Abuse (critical 9.1)
- [CVE-2022-40186](https://insights.sbomify.com/CVE-2022-40186/): HashiCorp Vault vulnerable to incorrect metadata access (critical 9.1)
- [CVE-2022-36129](https://insights.sbomify.com/CVE-2022-36129/): Missing authorization in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-6468 and fix it if it is affected.

What it is: CVE-2024-6468 is a high-severity denial of service vulnerability in Hashicorp Vault, published on 11 Jul 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-6468 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/vault (Go): affected from 1.10.0; fixed in 1.16.3, 1.17.2
- github.com/hashicorp/vault (Go): affected from 1.10.0; fixed in 1.15.12
- github.com/hashicorp/vault (Go): affected from 1.10.0; fixed in 1.15.12
- github.com/hashicorp/vault (Go): affected from 1.16.0-rc1; fixed in 1.16.3
- github.com/hashicorp/vault (Go): affected from 1.16.0-rc1; fixed in 1.16.3
- github.com/hashicorp/vault (Go): affected from 1.17.0-rc1; fixed in 1.17.2
- github.com/hashicorp/vault (Go): affected from 1.17.0-rc1; fixed in 1.17.2
- vault (Bitnami): affected from 1.10.0; fixed in 1.16.3, 1.17.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-6468/ (Markdown: https://insights.sbomify.com/CVE-2024-6468/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-6468
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-6468
- OSV: https://osv.dev/vulnerability/CVE-2024-6468

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-6468/
Summaries are generated and may contain mistakes; the official description above is the record.
