CVE-2024-6482 Login with phone number <= 1.7.49 - Authenticated (Subscriber+) Authorization Bypass to Privilege Escalation
Authenticated subscribers can escalate privileges to Administrator due to missing capability checks in the Login with phone number plugin.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2024-6482?
CVE-2024-6482 is a high-severity vulnerability in glboy OTP Login With Phone Number, OTP Verification, published on 14 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The Login with phone number plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 1.7.49. This is due to a lack of validation and missing capability check on user-supplied data in the 'lwp_update_password_action' function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update their role to any other role, including Administrator. The vulnerability was partially patched in version 1.7.40. The login with phone number pro plugin was required to exploit the vulnerability in versions 1.7.40 - 1.7.49.
Weakness: CWE-269
Which versions are affected by CVE-2024-6482?
It affects 1 product.
Products include Idehweb Login With Phone Number.
How do I fix CVE-2024-6482?
No fix has been published for CVE-2024-6482 yet. Limit exposure of the affected software until one is available.
Is CVE-2024-6482 being exploited?
There is no known exploitation of CVE-2024-6482 in the wild and no public exploit code.
Other vulnerabilities in glboy OTP Login With Phone Number, OTP Verification
- CVE-2023-4916 Login with phone number <= 1.5.6 - Cross-Site Request Forgery to User Password Change
- CVE-2023-23492 SQL injection in Login with Phone Number WordPress Plugin
- CVE-2022-0593 Login with phone number < 1.3.7 - Unauthenticated remote plugin deletion
- CVE-2024-37429 WordPress Login with phone number plugin <= 1.7.35 - Admin+ Cross Site Scripting (XSS) vulnerability
- CVE-2022-0598 Login with phone number < 1.3.8 - Multiple Admin+ Stored XSS
Sources
Also known as GHSA-gx7g-q2xr-xm5f.