{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-6482 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2024-6482 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-6482 is a high-severity vulnerability in glboy OTP Login With Phone Number, OTP Verification, published on 14 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-6482 and fix it if it is affected.\n\nWhat it is: CVE-2024-6482 is a high-severity vulnerability in glboy OTP Login With Phone Number, OTP Verification, published on 14 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-6482 in the wild and no public exploit code.\n\nAffected product: glboy OTP Login With Phone Number, OTP Verification. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-6482/ (Markdown: https://insights.sbomify.com/CVE-2024-6482/index.md)","id":"CVE-2024-6482","markdown":"https://insights.sbomify.com/CVE-2024-6482/index.md","name":"CVE-2024-6482","record":{"aliases":["GHSA-gx7g-q2xr-xm5f"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Authenticated subscribers can escalate privileges to Administrator due to missing capability checks in the Login with phone number plugin.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[{"product":"login_with_phone_number","vendor":"idehweb"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"The Login with phone number plugin for WordPress is vulnerable to privilege escalation in all versions up to, and including, 1.7.49. This is due to a lack of validation and missing capability check on user-supplied data in the 'lwp_update_password_action' function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update their role to any other role, including Administrator. The vulnerability was partially patched in version 1.7.40. The login with phone number pro plugin was required to exploit the vulnerability in versions 1.7.40 - 1.7.49.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Login with phone number \u003c= 1.7.49 - Authenticated (Subscriber+) Authorization Bypass to Privilege Escalation","id":"CVE-2024-6482","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2024"},"n_packages":0,"n_references":3,"next":{"headline":"Arbitrary File/Directory Deletion in aimhubio/aim","id":"CVE-2024-6483"},"packages":[],"prev":{"headline":"Search Filter Pro \u003c 2.5.18 - Admin+ Stored XSS","id":"CVE-2024-6481"},"products":["OTP Login With Phone Number, OTP Verification"],"published":"2024-09-14","related":[{"cvss_score":8.8,"headline":"Login with phone number \u003c= 1.5.6 - Cross-Site Request Forgery to User Password Change","id":"CVE-2023-4916","kev_date_added":null,"published":"2023-09-13"},{"cvss_score":8.8,"headline":"SQL injection in Login with Phone Number WordPress Plugin","id":"CVE-2023-23492","kev_date_added":null,"published":"2023-01-20"},{"cvss_score":6.5,"headline":"Login with phone number \u003c 1.3.7 - Unauthenticated remote plugin deletion","id":"CVE-2022-0593","kev_date_added":null,"published":"2022-03-14"},{"cvss_score":5.9,"headline":"WordPress Login with phone number plugin \u003c= 1.7.35 - Admin+ Cross Site Scripting (XSS) vulnerability","id":"CVE-2024-37429","kev_date_added":null,"published":"2024-07-22"},{"cvss_score":4.8,"headline":"Login with phone number \u003c 1.3.8 - Multiple Admin+ Stored XSS","id":"CVE-2022-0598","kev_date_added":null,"published":"2022-08-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["glboy"]},"summary":"Authenticated subscribers can escalate privileges to Administrator due to missing capability checks in the Login with phone number plugin.","url":"https://insights.sbomify.com/CVE-2024-6482/"}