{"answers":{"affected":"2 open source packages ship an affected version, including bootstrap.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6485 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2024-6485 is a medium-severity cross-site scripting vulnerability in Bootstrap, published on 11 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-6485 and fix it if it is affected.\n\nWhat it is: CVE-2024-6485 is a medium-severity cross-site scripting vulnerability in Bootstrap, published on 11 Jul 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6485 exists.\n\nAffected packages and fixed versions:\n- bootstrap (npm): affected from 1.4.0 up to 3.4.1; no fix listed\n- bootstrap (npm): affected from 1.4.0 up to 3.4.1; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-6485/ (Markdown: https://insights.sbomify.com/CVE-2024-6485/index.md)","id":"CVE-2024-6485","markdown":"https://insights.sbomify.com/CVE-2024-6485/index.md","name":"CVE-2024-6485","record":{"aliases":["AZL-105104","AZL-105134","AZL-105158","AZL-105206","AZL-105272","AZL-71317","DEBIAN-CVE-2024-6485","DLA-4124-1","GHSA-vxmc-5x29-h64v","ROOT-APP-NPM-CVE-2024-6485","UBUNTU-CVE-2024-6485"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Bootstrap frontend library","requires_auth":"none","summary":"Attackers can execute arbitrary JavaScript via the data-loading-text attribute in Bootstrap buttons, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"HeroDevs","cpe":[],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A security vulnerability has been discovered in bootstrap that could enable Cross-Site Scripting (XSS) attacks. The vulnerability is associated with the data-loading-text attribute within the button plugin. This vulnerability can be exploited by injecting malicious JavaScript code into the attribute, which would then be executed when the button's loading state is triggered.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2025-07-21","github_poc":1,"max_poc_stars":4,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-07-21T08:52:37Z","kind":"github_poc","ref":"https://github.com/Yumeae/Bootstrap-with-XSS","stars":4,"title":"A poc for Bootstrap XSS(CVE-2024-6485、CVE-2016-10735、CVE-2019-8331、CVE-2018-14040)"}],"tier":"weaponised"},"has_fix":true,"headline":"XSS in Bootstrap button component","id":"CVE-2024-6485","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"ImageMagick Engine \u003c 1.7.11 - Administrator+ OS Command Injection","id":"CVE-2024-6486"},"packages":[{"ecosystem":"npm","fixed":[],"introduced":["1.4.0"],"last_affected":["3.4.1"],"package":"bootstrap","purl":null,"source":"GHSA-vxmc-5x29-h64v"},{"ecosystem":"npm","fixed":[],"introduced":["1.4.0"],"last_affected":["3.4.1"],"package":"bootstrap","purl":"pkg:npm/bootstrap","source":"GHSA-vxmc-5x29-h64v"}],"prev":{"headline":"This was not a security issue in Bootstrap.","id":"CVE-2024-6484"},"products":["Bootstrap","bootstrap-sass"],"published":"2024-07-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["Bootstrap","Bootstrap-sass"]},"summary":"Attackers can execute arbitrary JavaScript via the data-loading-text attribute in Bootstrap buttons, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2024-6485/"}