{"answers":{"affected":"3 open source packages ship an affected version, including litellm. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6587 exists.","fix":"Upgrade litellm to 1.44.8 or later.","what":"CVE-2024-6587 is a high-severity server-side request forgery vulnerability in berriai/litellm, published on 13 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-6587 and fix it if it is affected.\n\nWhat it is: CVE-2024-6587 is a high-severity server-side request forgery vulnerability in berriai/litellm, published on 13 Sep 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6587 exists.\n\nAffected packages and fixed versions:\n- litellm (PyPI): affected all versions; fixed in 1.44.8\n- litellm (PyPI): affected all versions; fixed in 1.44.8\n- litellm (PyPI): affected all versions; fixed in 1.44.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-6587/ (Markdown: https://insights.sbomify.com/CVE-2024-6587/index.md)","id":"CVE-2024-6587","markdown":"https://insights.sbomify.com/CVE-2024-6587/index.md","name":"CVE-2024-6587","record":{"aliases":["GHSA-g26j-5385-hhw3","PYSEC-2026-1547"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"LiteLLM Python library","requires_auth":"none","summary":"Attackers can intercept OpenAI API keys by specifying a malicious api_base in chat completion requests, leading to unauthorized access.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[{"product":"litellm","vendor":"litellm"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"A Server-Side Request Forgery (SSRF) vulnerability exists in berriai/litellm version 1.38.10. This vulnerability allows users to specify the `api_base` parameter when making requests to `POST /chat/completions`, causing the application to send the request to the domain specified by `api_base`. This request includes the OpenAI API key. A malicious user can set the `api_base` to their own domain and intercept the OpenAI API key, leading to unauthorized access and potential misuse of the API key.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":1,"refs":[{"date":null,"kind":"nuclei","ref":"http/cves/2024/CVE-2024-6587.yaml","stars":null,"title":"LiteLLM - Server-Side Request Forgery"}],"tier":"weaponised"},"has_fix":true,"headline":"SSRF in berriai/litellm","id":"CVE-2024-6587","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"ssrf","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Cross-site scripting in PowerPress Podcasting plugin by Blubrry","id":"CVE-2024-6588"},"packages":[{"ecosystem":"PyPI","fixed":["1.44.8"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":null,"source":"GHSA-g26j-5385-hhw3"},{"ecosystem":"PyPI","fixed":["1.44.8"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":"pkg:pypi/litellm","source":"GHSA-g26j-5385-hhw3"},{"ecosystem":"PyPI","fixed":["1.44.8"],"introduced":["0"],"last_affected":[],"package":"litellm","purl":"pkg:pypi/litellm","source":"PYSEC-2026-1547"}],"prev":{"headline":"Server-side request forgery in Lightdash","id":"CVE-2024-6586"},"products":["berriai/litellm"],"published":"2024-09-13","related":[{"cvss_score":9.3,"headline":"BerriAI LiteLLM SQL Injection","id":"CVE-2026-42208","kev_date_added":"2026-05-08","published":"2026-05-08"},{"cvss_score":8.8,"headline":"BerriAI LiteLLM Improper Authentication","id":"CVE-2026-59822","kev_date_added":"2026-09-02","published":"2026-07-08"},{"cvss_score":8.7,"headline":"BerriAI LiteLLM Command Injection","id":"CVE-2026-42271","kev_date_added":"2026-06-08","published":"2026-05-08"},{"cvss_score":9.8,"headline":"Remote Code Execution in BerriAI/litellm","id":"CVE-2024-5751","kev_date_added":null,"published":"2024-06-27"},{"cvss_score":9.8,"headline":"Server-Side Template Injection in BerriAI/litellm","id":"CVE-2024-2952","kev_date_added":null,"published":"2024-04-10"},{"cvss_score":9.5,"headline":"LiteLLM: Authentication Bypass via Host Header Injection","id":"CVE-2026-49468","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":9.4,"headline":"LiteLLM has an authentication bypass via OIDC userinfo cache key collision","id":"CVE-2026-35030","kev_date_added":null,"published":"2026-04-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-09-13","vendors":["berriai"]},"summary":"Attackers can intercept OpenAI API keys by specifying a malicious api_base in chat completion requests, leading to unauthorized access.","url":"https://insights.sbomify.com/CVE-2024-6587/"}