CVE-2024-6595 Uncontrolled Search Path Element in GitLab
Attackers can upload malicious NPM packages with conflicting data, potentially leading to code execution or privilege escalation in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-6595?
CVE-2024-6595 is a low-severity vulnerability in Gitlab Gitlab, published on 17 Jul 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
An issue was discovered in GitLab CE/EE affecting all versions starting from 11.8 prior to 16.11.6, starting from 17.0 prior to 17.0.4, and starting from 17.1 prior to 17.1.2 where it was possible to upload an NPM package with conflicting package data.
Which versions are affected by CVE-2024-6595?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 11.8.0 | 16.11.6, 17.0.4, 17.1.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-6595?
Upgrade gitlab to a fixed version for your release line: 16.11.6, 17.0.4 or 17.1.2.
Is CVE-2024-6595 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6595 exists.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-6595, GHSA-5qwh-g35c-5mmm, UBUNTU-CVE-2024-6595.