CVE-2024-6678 Authentication Bypass by Spoofing in GitLab

Critical 9.9 Published Updated

An attacker can trigger CI/CD pipelines as an arbitrary user, potentially leading to privilege escalation or code execution in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-6678?

CVE-2024-6678 is a critical authentication bypass vulnerability in Gitlab Gitlab, published on 12 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue was discovered in GitLab CE/EE affecting all versions starting from 8.14 prior to 17.1.7, starting from 17.2 prior to 17.2.5, and starting from 17.3 prior to 17.3.2, which allows an attacker to trigger a pipeline as an arbitrary user under certain circumstances.

Weakness: CWE-290

Which versions are affected by CVE-2024-6678?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 8.14.017.1.7, 17.2.5, 17.3.2

Products include Gitlab Gitlab.

How do I fix CVE-2024-6678?

Upgrade gitlab to a fixed version for your release line: 17.1.7, 17.2.5 or 17.3.2.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2024-6678 being exploited?

There is no known exploitation of CVE-2024-6678 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-6678, GHSA-ph8h-4mq7-vw5v, UBUNTU-CVE-2024-6678.

Is CVE-2024-6678 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free