CVE-2024-6685 Authorization Bypass Through User-Controlled Key in GitLab
Unauthorized group members can access sensitive group runner information due to improper authorization checks in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-6685?
CVE-2024-6685 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 16 Sep 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in GitLab CE/EE affecting all versions starting from 16.7 prior to 17.1.7, 17.2 prior to 17.2.5, and 17.3 prior to 17.3.2, where group runners information was disclosed to unauthorised group members.
Weakness: CWE-639
Which versions are affected by CVE-2024-6685?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 16.7.0 | 17.1.7, 17.2.5, 17.3.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2024-6685?
Upgrade gitlab to a fixed version for your release line: 17.1.7, 17.2.5 or 17.3.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2024-6685 being exploited?
There is no known exploitation of CVE-2024-6685 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2024-6685, GHSA-272r-9r62-xgwc, UBUNTU-CVE-2024-6685.