# CVE-2024-6706: Open WebUI Stored Cross-Site Scripting

> Attackers can inject malicious JavaScript via crafted prompts, allowing arbitrary code execution in the victim's browser context.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Aug 2024
- **Updated:** 8 Aug 2024
- **Also known as:** GHSA-5jp3-wp5v-5363, PYSEC-2026-1722

## What is CVE-2024-6706?

CVE-2024-6706 is a medium-severity cross-site scripting vulnerability in Openwebui Open Webui, published on 7 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Attackers can craft a malicious prompt that coerces the language model into executing arbitrary JavaScript in the context of the web page.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-6706?

3 open source packages ship an affected version, including open-webui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `open-webui` | PyPI | All versions | 0.3.14 |
| `open-webui` | PyPI | All versions | 0.3.14 |
| `open-webui` | PyPI | All versions | 0.3.14 |

Products: Openwebui Open Webui.

## How do I fix CVE-2024-6706?

Upgrade open-webui to 0.3.14 or later.

## Is CVE-2024-6706 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6706 exists.

## Other vulnerabilities in Openwebui Open Webui

- [CVE-2026-44551](https://insights.sbomify.com/CVE-2026-44551/): Open WebUI: LDAP Empty Password Authentication Bypass (critical 9.1)
- [CVE-2026-56400](https://insights.sbomify.com/CVE-2026-56400/): open-webui - Remote Code Execution via CORS Misconfiguration and Session Validation (critical 9.0)
- [CVE-2024-8017](https://insights.sbomify.com/CVE-2024-8017/): Cross-site Scripting (XSS) in open-webui/open-webui (critical 9.0)
- [CVE-2026-45672](https://insights.sbomify.com/CVE-2026-45672/): Open WebUI: Jupyter code execution works despite `ENABLE_CODE_EXECUTION=false` — feature gate bypassed (high 8.8)
- [CVE-2026-87995](https://insights.sbomify.com/CVE-2026-87995/): Open WebUI: Same-origin XSS to account takeover via terminal port-preview iframe hardcoding allow-same-origin (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-6706 and fix it if it is affected.

What it is: CVE-2024-6706 is a medium-severity cross-site scripting vulnerability in Openwebui Open Webui, published on 7 Aug 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6706 exists.

Affected packages and fixed versions:
- open-webui (PyPI): affected all versions; fixed in 0.3.14
- open-webui (PyPI): affected all versions; fixed in 0.3.14
- open-webui (PyPI): affected all versions; fixed in 0.3.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-6706/ (Markdown: https://insights.sbomify.com/CVE-2024-6706/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-6706
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-6706
- OSV: https://osv.dev/vulnerability/CVE-2024-6706

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-6706/
Summaries are generated and may contain mistakes; the official description above is the record.
