CVE-2024-6717 Nomad Vulnerable to Allocation Directory Path Escape Through Archive Unpacking
Attackers can escape allocation directories during archive unpacking in HashiCorp Nomad, potentially modifying files or executing code.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-6717?
CVE-2024-6717 is a high-severity path traversal vulnerability in HashiCorp Nomad, published on 23 Jul 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
HashiCorp Nomad and Nomad Enterprise 1.6.12 up to 1.7.9, and 1.8.1 archive unpacking during migration is vulnerable to path escaping of the allocation directory. This vulnerability, CVE-2024-6717, is fixed in Nomad 1.6.13, 1.7.10, and 1.8.2.
Weakness: CWE-610
Which versions are affected by CVE-2024-6717?
3 open source packages ship an affected version, including github.com/hashicorp/nomad. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/hashicorp/nomad Go | All versions | 1.11.1 |
github.com/hashicorp/nomad Go | All versions | 1.8.2 |
github.com/hashicorp/nomad Go | All versions | 1.8.2 |
Products include Hashicorp Nomad.
How do I fix CVE-2024-6717?
Upgrade github.com/hashicorp/nomad to a fixed version for your release line: 1.11.1 or 1.8.2.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2024-6717 being exploited?
There is no known exploitation of CVE-2024-6717 in the wild and no public exploit code.
Other vulnerabilities in HashiCorp Nomad
- CVE-2023-1782 Nomad Unauthenticated Client Agent HTTP Request Privilege Escalation
- CVE-2022-30324 Privilege escalation in Hashicorp Nomad
- CVE-2020-7956 Improper Certificate Validation in HashiCorp Nomad
- CVE-2019-12618 Hashicorp Nomad Access Control Issues
- CVE-2020-27195 Use After Free in HashiCorp Nomad
Sources
Also known as GHSA-5mqx-rpxv-mvxj, GO-2026-4278, UBUNTU-CVE-2024-6717.