# CVE-2024-6763: Jetty URI parsing of invalid authority

> Attackers can exploit URI parsing discrepancies to perform open redirects or SSRF attacks against applications using Jetty.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2024
- **Updated:** 7 Mar 2025
- **Also known as:** CLEANSTART-2026-JA72331, CLEANSTART-2026-KU65469, CLEANSTART-2026-MU41312, CLEANSTART-2026-UD88667, CLSA-2026-1790803421, DEBIAN-CVE-2024-6763, ECHO-5fe2-1509-4308, GHSA-qh8g-58pp-2wxh, MINI-3628-5mj3-8pvc, MINI-57c2-cwhp-5hc8, MINI-57h2-rq8p-g89h, MINI-5854-5jpw-7qp6, MINI-6c44-chfc-w9jw, MINI-6qp7-x26h-rm93, MINI-6wj2-mhq9-v4m6, MINI-8h6w-xmqf-5rqw, MINI-97cr-vxj2-xhw6, MINI-99f8-437v-w86g, MINI-c7rc-6m9w-3qm3, MINI-cqwq-jwq9-3f6v, MINI-fqhc-wqc2-2w96, MINI-h3v4-q2f3-vf78, MINI-h7fg-7663-fmvw, MINI-hrgg-c59v-xmc4, MINI-j96j-hg2w-4r85, MINI-jrm5-4p22-7397, MINI-jxpg-7w7j-89mx, MINI-m5wx-pvg5-xq6m, MINI-mmv7-5626-wv3f, MINI-q86r-qp2p-h4h4, MINI-r2rf-8q4c-8xqw, MINI-v47m-3gw4-xpjm, MINI-v94x-fc4x-932p, MINI-vg3j-h9x4-rrw3, MINI-vwgg-8w68-gcwx, MINI-w8jf-gw77-jwxh, MINI-wf9r-6x43-2qfw, MINI-wfq6-6g2j-w4gm, MINI-wrgh-q3h2-ppc8, MINI-x9vm-mj6q-x9m8, ROOT-APP-MAVEN-CVE-2024-6763, UBUNTU-CVE-2024-6763

## What is CVE-2024-6763?

CVE-2024-6763 is a low-severity vulnerability in Eclipse Jetty, published on 14 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Eclipse Jetty is a lightweight, highly scalable, Java-based web server and Servlet engine . It includes a utility class, HttpURI, for URI/URL parsing.

The HttpURI class does insufficient validation on the authority segment of a URI.  However the behaviour of HttpURI
 differs from the common browsers in how it handles a URI that would be 
considered invalid if fully validated against the RRC.  Specifically HttpURI
 and the browser may differ on the value of the host extracted from an 
invalid URI and thus a combination of Jetty and a vulnerable browser may
 be vulnerable to a open redirect attack or to a SSRF attack if the URI 
is used after passing validation checks.

Weakness: CWE-1286 (Improper Validation of Syntactic Correctness of Input)

## Which versions are affected by CVE-2024-6763?

2 open source packages ship an affected version, including org.eclipse.jetty:jetty-http. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.jetty:jetty-http` | Maven | From 7.0.0 | 12.0.12 |
| `org.eclipse.jetty:jetty-http` | Maven | From 7.0.0 | 12.0.12 |

Products: Eclipse Jetty.

## How do I fix CVE-2024-6763?

Upgrade org.eclipse.jetty:jetty-http to 12.0.12 or later.

## Is CVE-2024-6763 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6763 exists.

## Other vulnerabilities in Eclipse Jetty

- [CVE-2016-4800](https://insights.sbomify.com/CVE-2016-4800/): Jetty contains an alias issue that could allow unauthenticated remote code execution due to specially crafted request (critical 9.8)
- [CVE-2019-17638](https://insights.sbomify.com/CVE-2019-17638/): Operation on a Resource after Expiration or Release in Jetty Server (critical 9.4)
- [CVE-2018-12538](https://insights.sbomify.com/CVE-2018-12538/): Access and integrity issue within Eclipse Jetty (high 8.8)
- [CVE-2026-10050](https://insights.sbomify.com/CVE-2026-10050/): Digest authentication lossy encoding (high 8.7)
- [CVE-2025-5115](https://insights.sbomify.com/CVE-2025-5115/): MadeYouReset HTTP/2 vulnerability (high 7.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-6763 and fix it if it is affected.

What it is: CVE-2024-6763 is a low-severity vulnerability in Eclipse Jetty, published on 14 Oct 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6763 exists.

Affected packages and fixed versions:
- org.eclipse.jetty:jetty-http (Maven): affected from 7.0.0; fixed in 12.0.12
- org.eclipse.jetty:jetty-http (Maven): affected from 7.0.0; fixed in 12.0.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-6763/ (Markdown: https://insights.sbomify.com/CVE-2024-6763/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-6763
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-6763
- OSV: https://osv.dev/vulnerability/CVE-2024-6763

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-6763/
Summaries are generated and may contain mistakes; the official description above is the record.
