{"answers":{"affected":"3 open source packages ship an affected version, including litellm. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6825 exists.","fix":"No fix has been published for CVE-2024-6825 yet. Limit exposure of the affected software until one is available.","what":"CVE-2024-6825 is a high-severity code injection vulnerability in berriai/litellm, published on 20 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-6825 and fix it if it is affected.\n\nWhat it is: CVE-2024-6825 is a high-severity code injection vulnerability in berriai/litellm, published on 20 Mar 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6825 exists.\n\nAffected packages and fixed versions:\n- litellm (PyPI): affected from 1.40.3.dev2 up to 1.40.12; no fix listed\n- litellm (PyPI): affected from 1.40.3.dev2 up to 1.40.12; no fix listed\n- litellm (PyPI): affected from 1.40.3.dev2 up to 1.40.12; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-6825/ (Markdown: https://insights.sbomify.com/CVE-2024-6825/index.md)","id":"CVE-2024-6825","markdown":"https://insights.sbomify.com/CVE-2024-6825/index.md","name":"CVE-2024-6825","record":{"aliases":["GHSA-53gh-p8jc-7rg8","PYSEC-2026-1541"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Python LLM library","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary code by injecting malicious callbacks into the post_call_rules configuration in LiteLLM.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[{"product":"litellm","vendor":"litellm"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"BerriAI/litellm version 1.40.12 contains a vulnerability that allows remote code execution. The issue exists in the handling of the 'post_call_rules' configuration, where a callback function can be added. The provided value is split at the final '.' mark, with the last part considered the function name and the remaining part appended with the '.py' extension and imported. This allows an attacker to set a system method, such as 'os.system', as a callback, enabling the execution of arbitrary commands when a chat response is processed.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Remote Code Execution in BerriAI/litellm","id":"CVE-2024-6825","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Allocation of Resources Without Limits or Throttling in GitLab","id":"CVE-2024-6826"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["1.40.3.dev2"],"last_affected":["1.40.12"],"package":"litellm","purl":null,"source":"GHSA-53gh-p8jc-7rg8"},{"ecosystem":"PyPI","fixed":[],"introduced":["1.40.3.dev2"],"last_affected":["1.40.12"],"package":"litellm","purl":"pkg:pypi/litellm","source":"GHSA-53gh-p8jc-7rg8"},{"ecosystem":"PyPI","fixed":[],"introduced":["1.40.3.dev2"],"last_affected":["1.40.12"],"package":"litellm","purl":"pkg:pypi/litellm","source":"PYSEC-2026-1541"}],"prev":{"headline":"Missing authorization in Premium Addons for Elementor – Powerful Elementor Templates \u0026 Widgets","id":"CVE-2024-6824"},"products":["berriai/litellm"],"published":"2025-03-20","related":[{"cvss_score":9.3,"headline":"BerriAI LiteLLM SQL Injection","id":"CVE-2026-42208","kev_date_added":"2026-05-08","published":"2026-05-08"},{"cvss_score":8.8,"headline":"BerriAI LiteLLM Improper Authentication","id":"CVE-2026-59822","kev_date_added":"2026-09-02","published":"2026-07-08"},{"cvss_score":8.7,"headline":"BerriAI LiteLLM Command Injection","id":"CVE-2026-42271","kev_date_added":"2026-06-08","published":"2026-05-08"},{"cvss_score":9.8,"headline":"Remote Code Execution in BerriAI/litellm","id":"CVE-2024-5751","kev_date_added":null,"published":"2024-06-27"},{"cvss_score":9.8,"headline":"Server-Side Template Injection in BerriAI/litellm","id":"CVE-2024-2952","kev_date_added":null,"published":"2024-04-10"},{"cvss_score":9.5,"headline":"LiteLLM: Authentication Bypass via Host Header Injection","id":"CVE-2026-49468","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":9.4,"headline":"LiteLLM has an authentication bypass via OIDC userinfo cache key collision","id":"CVE-2026-35030","kev_date_added":null,"published":"2026-04-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-10-15","vendors":["berriai"]},"summary":"Attackers can execute arbitrary code by injecting malicious callbacks into the post_call_rules configuration in LiteLLM.","url":"https://insights.sbomify.com/CVE-2024-6825/"}