CVE-2024-6826 Allocation of Resources Without Limits or Throttling in GitLab

Medium 6.5 Published Updated

An attacker can cause a denial of service in GitLab by importing a maliciously crafted XML manifest file.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-6826?

CVE-2024-6826 is a medium-severity denial of service vulnerability in Gitlab Gitlab, published on 24 Oct 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 11.2 before 17.3.6, 17.4 before 17.4.3, and 17.5 before 17.5.1. A denial of service could occur via importing a malicious crafted XML manifest file.

Weakness: CWE-770

Which versions are affected by CVE-2024-6826?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 11.2.017.3.6, 17.4.3, 17.5.1

Products include Gitlab Gitlab.

How do I fix CVE-2024-6826?

Upgrade gitlab to a fixed version for your release line: 17.3.6, 17.4.3 or 17.5.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2024-6826 being exploited?

There is no known exploitation of CVE-2024-6826 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2024-6826, GHSA-28m9-57g2-hv97, UBUNTU-CVE-2024-6826.

Is CVE-2024-6826 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free