# CVE-2024-6833: Zowe CLI Auto-Init Leaks Credentials Locally

> Local privileged actors can access plaintext credentials stored by Zowe CLI during auto-init operations, exposing sensitive authentication data.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:C/C:H/I:N/A:N/E:P/RL:O/RC:C/CR:M/IR:X/AR:X/MAV:L/MAC:L/MPR:L/MUI:R/MS:C/MC:H/MI:N/MA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Jul 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-ghgq-x6wc-6jr5

## What is CVE-2024-6833?

CVE-2024-6833 is a medium-severity vulnerability in Open Mainframe Project Zowe, published on 17 Jul 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A vulnerability in Zowe CLI allows local, privileged actors to store previously entered secure credentials in a plaintext file as part of an auto-init operation.

## Which versions are affected by CVE-2024-6833?

2 open source packages ship an affected version, including @zowe/cli.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@zowe/cli` | npm | From 7.18.0 | 7.23.5 |
| `@zowe/cli` | npm | From 7.18.0 | 7.23.5 |

## How do I fix CVE-2024-6833?

Upgrade @zowe/cli to 7.23.5 or later.

## Is CVE-2024-6833 being exploited?

There is no known exploitation of CVE-2024-6833 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-6833 and fix it if it is affected.

What it is: CVE-2024-6833 is a medium-severity vulnerability in Open Mainframe Project Zowe, published on 17 Jul 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-6833 in the wild and no public exploit code.

Affected packages and fixed versions:
- @zowe/cli (npm): affected from 7.18.0; fixed in 7.23.5
- @zowe/cli (npm): affected from 7.18.0; fixed in 7.23.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-6833/ (Markdown: https://insights.sbomify.com/CVE-2024-6833/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-6833
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-6833
- OSV: https://osv.dev/vulnerability/CVE-2024-6833

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-6833/
Summaries are generated and may contain mistakes; the official description above is the record.
