# CVE-2024-6844: Inconsistent CORS Matching Due to Handling of '+' in URL Path in corydolphin/flask-cors

> Attackers can bypass CORS restrictions due to inconsistent path matching caused by '+' character handling in the flask-cors library.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2025
- **Updated:** 3 Nov 2025
- **Also known as:** CLSA-2026-1781139191, DEBIAN-CVE-2024-6844, ECHO-4cff-5ded-70e4, GHSA-8vgw-p6qm-5gr7, PYSEC-2026-1385, ROOT-APP-PYPI-CVE-2024-6844, UBUNTU-CVE-2024-6844

## What is CVE-2024-6844?

CVE-2024-6844 is a medium-severity vulnerability in corydolphin/flask-cors, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in corydolphin/flask-cors version 4.0.1 allows for inconsistent CORS matching due to the handling of the '+' character in URL paths. The request.path is passed through the unquote_plus function, which converts the '+' character to a space ' '. This behavior leads to incorrect path normalization, causing potential mismatches in CORS configuration. As a result, endpoints may not be matched correctly to their CORS settings, leading to unexpected CORS policy application. This can cause unauthorized cross-origin access or block valid requests, creating security vulnerabilities and usability issues.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2024-6844?

3 open source packages ship an affected version, including flask-cors. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flask-cors` | PyPI | All versions | 6.0.0 |
| `flask-cors` | PyPI | All versions | 6.0.0 |
| `flask-cors` | PyPI | All versions | 6.0.0 |

Products: Flask-Cors Project Flask-Cors.

## How do I fix CVE-2024-6844?

Upgrade flask-cors to 6.0.0 or later.

## Is CVE-2024-6844 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6844 exists.

## Other vulnerabilities in corydolphin/flask-cors

- [CVE-2024-6866](https://insights.sbomify.com/CVE-2024-6866/): Case-Insensitive Path Matching in corydolphin/flask-cors (medium 5.3)
- [CVE-2024-6839](https://insights.sbomify.com/CVE-2024-6839/): Improper Regex Path Matching in corydolphin/flask-cors (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-6844 and fix it if it is affected.

What it is: CVE-2024-6844 is a medium-severity vulnerability in corydolphin/flask-cors, published on 20 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-6844 exists.

Affected packages and fixed versions:
- flask-cors (PyPI): affected all versions; fixed in 6.0.0
- flask-cors (PyPI): affected all versions; fixed in 6.0.0
- flask-cors (PyPI): affected all versions; fixed in 6.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-6844/ (Markdown: https://insights.sbomify.com/CVE-2024-6844/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-6844
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-6844
- OSV: https://osv.dev/vulnerability/CVE-2024-6844

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-6844/
Summaries are generated and may contain mistakes; the official description above is the record.
